Uploaded image for project: 'Karaf'
  1. Karaf
  2. KARAF-2295

features deployer is useless for dynamic updates

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0.RC1
    • Fix Version/s: 3.0.2, 4.0.0.M3
    • Component/s: karaf-feature
    • Labels:
      None

      Description

      use cases which do not work:

      suppose old and new repository contain overlapping set of bundles.

      1) same name, new version:

      a) install

      • drop repo-1.0-features.xml

      b) update

      • kill repo-1.0-features.xml
      • drop repo-1.1-features.xml

      2) same name, no version:

      a) install

      • drop repo-features.xml

      b) update

      • drop repo-features.xml

      result: total corruption of repository, feature, bundle install state

      workaround: clean bundle cache, restart karaf.

      description why it does not work:
      https://github.com/barchart/barchart-service/wiki/Features-Problems

      re-implementation of features deployer
      https://github.com/barchart/barchart-karaf-deployer-features

        Issue Links

          Activity

          Hide
          jbonofre Jean-Baptiste Onofré added a comment -

          It has been fixed as part of KARAF-2637

          Show
          jbonofre Jean-Baptiste Onofré added a comment - It has been fixed as part of KARAF-2637

            People

            • Assignee:
              jbonofre Jean-Baptiste Onofré
              Reporter:
              andrei.pozolotin Andrei Pozolotin
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development