Uploaded image for project: 'Karaf'
  1. Karaf
  2. KARAF-2289

AJAX Error when editing some configurations in webconsole

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.1
    • Fix Version/s: 2.3.4
    • Component/s: webconsole
    • Labels:
      None
    • Environment:

      Windows 7 Pro x64

      Description

      I was working through Christian Schneider's Karaf tutorial #3 (http://www.liquid-reality.de/display/liquid/2011/09/26/Karaf+Tutorial+Part+3+-+Improving+configuration+editing+using+the+OSGI+Metatype+Service+and+the+Felix+Webconsole). After presenting my findings to Christian, he believes this is a bug in the webconsole for this version of Karaf, and asked me if I could open an issue here.

      The problem is that after building his ConfigAdmin project & installing in Karaf, if you attempt to edit that project's configuration (ConfigApp.cfg) file through the webconsole, the following error is raised:
      AJAX Error
      The request failed:
      {"PID":"ConfigAdmin"

      If I uninstall the configapp & configapp-blueprint features, I can then edit the remaining ConfigApp.cfg file through the webconsole, receiving the message that the form was automatically generated because no property descriptors are available (which makes sense because I uninstalled the associated features).

      His tutorial references Karaf 2.2.4 which did not have this problem, and he has tested in 3.0.0.RC1 without seeing this problem. 2.3.1 however seems to have this issue.

        Activity

        jbonofre Jean-Baptiste Onofré added a comment -

        OK, it's a bug in Felix WebConsole 4.0.0. Upgrading to Felix WebConsole 4.2.0 fixes the problem.

        jbonofre Jean-Baptiste Onofré added a comment -

        It works fine on 2.4.0-SNAPSHOT too. I check if it's not a bug in Felix WebConsole (ConfigAdmin plugin).

        jbonofre Jean-Baptiste Onofré added a comment -

        It works fine on 3.0.1-SNAPSHOT.

        jbonofre Jean-Baptiste Onofré added a comment -

        The following configurations PID are affected:

        • org.apache.karaf.features.repos
        • org.apache.karaf.jaas
        • org.apache.karaf.kar
        • org.ops4j.pax.logging

        I'm fixing that.

        benjamindebeerst Benjamin Debeerst added a comment -

        This bug can be easily reproduced without any custom work like in the above linked tutorial:

        1. Run a clean Karaf 2.3.2 container
        2. Run features:install webconsole on the console
        3. In the webconsole, open the Configution tab
        4. Try to change the configuration for org.apache.karaf.jaas
        5. A AJAX Error is returned: The request failed: {"pid":"org.apache.karaf.jaas"
        jgoodyear Jamie goodyear added a comment -

        Bumping out to 2.3.3.

        riccardo.to Riccardo Tomasi added a comment -

        I confirm this bug under Xubuntu Linux 12.02 x86


          People

          • Assignee:
            jbonofre Jean-Baptiste Onofré
            Reporter:
            jacgec Jeff Clark
          • Votes:
            4 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development