Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.1
    • Fix Version/s: 2.3.2, 2.4.0, 3.0.0
    • Component/s: karaf-webconsole
    • Labels:
      None

      Description

      The Features tab in the WebConsole is blank.

      I saw that the plugin is activated too early (comparing to others Karaf WebConsole plugin like admin or gogo).

        Issue Links

          Activity

          jbonofre Jean-Baptiste Onofré added a comment -

          This problem only occurs with Equinox (not Felix Framework).

          jbonofre Jean-Baptiste Onofré added a comment -

          I saw that:

          • admin tab
          • gogo tab

          are also affected.

          So it means that all plugins provided by Karaf (not in Felix WebConsole) don't work with Equinox.

          jbonofre Jean-Baptiste Onofré added a comment -

          I tried with Felix WebConsole OBR plugin and it works on Equinox.

          For that, I add to "export" (from Karaf WebConsole), the org.json package in order to use it from the legacy plugin.

          The difference in this Felix WebConsole OBR plugin is that it doesn't use Blueprint, it directly use an Activator. I gonna make a try on one of our customer to avoid the usage of Blueprint if it can have an impact.

          jbonofre Jean-Baptiste Onofré added a comment -

          It seems that the problem is around the getResource() method in the plugins. I'm digging around that.

          jbonofre Jean-Baptiste Onofré added a comment -

          I found the issue: it's in the getResource() method. With Equinox, the classLoader.getResource(path) call never returns null, even if the path is empty (it returns bundleresource://... whereas with Felix, it returns null). That's why the first call (with action null) don't get the right resources.

          jbonofre Jean-Baptiste Onofré added a comment -

          Fixed Features WebConsole plugin on trunk: http://svn.apache.org/viewvc?view=revision&revision=1478370

          jbonofre Jean-Baptiste Onofré added a comment -

          Fixed Gogo WebConsole plugin on trunk: http://svn.apache.org/viewvc?view=revision&revision=1478372

          jbonofre Jean-Baptiste Onofré added a comment -

          Fixed Http WebConsole plugin on trunk: http://svn.apache.org/viewvc?view=revision&revision=1478377

          jbonofre Jean-Baptiste Onofré added a comment -

          Fixed Instance WebConsole plugin on trunk: http://svn.apache.org/viewvc?view=revision&revision=1478387

          jbonofre Jean-Baptiste Onofré added a comment -

          Fixed Features WebConsole plugin on karaf-2.x: http://svn.apache.org/viewvc?view=revision&revision=1478401

          jbonofre Jean-Baptiste Onofré added a comment -

          Fixed Admin WebConsole plugin on karaf-2.x: http://svn.apache.org/viewvc?view=revision&revision=1478407

          jbonofre Jean-Baptiste Onofré added a comment -

          Fixed Gogo WebConsole plugin on karaf-2.x: http://svn.apache.org/viewvc?view=revision&revision=1478413

          jbonofre Jean-Baptiste Onofré added a comment -

          Fixed Features WebConsole plugin on karaf-2.3.x: http://svn.apache.org/viewvc?view=revision&revision=1478443

          jbonofre Jean-Baptiste Onofré added a comment -

          Fixed Admin WebConsole plugin on karaf-2.3.x: http://svn.apache.org/viewvc?view=revision&revision=1478447

          jbonofre Jean-Baptiste Onofré added a comment -

          Fixed Gogo WebConsole plugon on karaf-2.3.x: http://svn.apache.org/viewvc?view=revision&revision=1478453


            People

            • Assignee:
              jbonofre Jean-Baptiste Onofré
              Reporter:
              jbonofre Jean-Baptiste Onofré
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development