Uploaded image for project: 'Karaf'
  1. Karaf
  2. KARAF-2255

SCR feature generates an error when deployed on Karaf 2.3.1

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.1
    • Fix Version/s: 2.3.2
    • Component/s: None
    • Labels:
      None

      Description

      When feature SCR is deployed on Karaf 2.3.1, then an error occurs

      karaf@root> features:install scr
      ERROR: Bundle org.ops4j.pax.web.pax-web-runtime [133] EventDispatcher: Error during dispatch. (java.lang.NoClassDefFoundError: org/osgi/service/event/EventAdmin)
      java.lang.NoClassDefFoundError: org/osgi/service/event/EventAdmin
      	at org.ops4j.pax.web.service.internal.Activator$EventServiceCustomizer.addingService(Activator.java:474)
      	at org.osgi.util.tracker.ServiceTracker$Tracked.customizerAdding(ServiceTracker.java:932)
      	at org.osgi.util.tracker.ServiceTracker$Tracked.customizerAdding(ServiceTracker.java:1)
      	at org.osgi.util.tracker.AbstractTracked.trackAdding(AbstractTracked.java:256)
      	at org.osgi.util.tracker.AbstractTracked.track(AbstractTracked.java:229)
      	at org.osgi.util.tracker.ServiceTracker$Tracked.serviceChanged(ServiceTracker.java:894)
      	at org.apache.felix.framework.util.EventDispatcher.invokeServiceListenerCallback(EventDispatcher.java:932)
      	at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:793)
      	at org.apache.felix.framework.util.EventDispatcher.fireServiceEvent(EventDispatcher.java:543)
      	at org.apache.felix.framework.Felix.fireServiceEvent(Felix.java:4260)
      	at org.apache.felix.framework.Felix.registerService(Felix.java:3275)
      	at org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:346)
      	at org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:320)
      	at org.apache.felix.eventadmin.impl.Configuration.startOrUpdate(Configuration.java:324)
      	at org.apache.felix.eventadmin.impl.Configuration.<init>(Configuration.java:142)
      	at org.apache.felix.eventadmin.impl.Activator.start(Activator.java:65)
      	at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:645)
      	at org.apache.felix.framework.Felix.activateBundle(Felix.java:1977)
      	at org.apache.felix.framework.Felix.startBundle(Felix.java:1895)
      	at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)
      	at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)
      	at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:473)
      	at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:393)
      	at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:389)
      	at org.apache.karaf.features.command.InstallFeatureCommand.doExecute(InstallFeatureCommand.java:62)
      	at org.apache.karaf.features.command.FeaturesCommandSupport.doExecute(FeaturesCommandSupport.java:41)
      	at org.apache.karaf.shell.console.OsgiCommandSupport.execute(OsgiCommandSupport.java:38)
      	at org.apache.felix.gogo.commands.basic.AbstractCommand.execute(AbstractCommand.java:35)
      	at org.apache.felix.gogo.runtime.CommandProxy.execute(CommandProxy.java:78)
      	at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:474)
      	at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:400)
      	at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)
      	at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)
      	at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)
      	at org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:89)
      	at org.apache.karaf.shell.console.jline.Console.run(Console.java:175)
      	at java.lang.Thread.run(Thread.java:680)
      Caused by: java.lang.ClassNotFoundException: org.osgi.service.event.EventAdmin not found by org.ops4j.pax.web.pax-web-runtime [133]
      	at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1460)
      	at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:72)
      	at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1843)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      

        Activity

        cmoulliard Charles Moulliard added a comment -

        We should perhaps add the following feature to scr to avoid this ERROR ?

        features:install eventadmin


          People

          • Assignee:
            jbonofre Jean-Baptiste Onofré
            Reporter:
            cmoulliard Charles Moulliard
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development