Uploaded image for project: 'Karaf'
  1. Karaf
  2. KARAF-2254

karaf-feature-archetype generates a feature.xml file which can not be add to featureUrl

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.3.2
    • Component/s: karaf-feature
    • Labels:
      None
    • Environment:

      karaf 2.3.0

      Description

      I use karaf-feature-archetype to generate a feature.xml
      And the xmlns is "http://karaf.apache.org/xmlns/features/v1.2.0"
      And this feature.xml cannot be add to feature url.
      I have read the code , I think it is because it can not accept v1.2.0.
      So I changed the xmlns to http://karaf.apache.org/xmlns/features/v1.0.0
      It worked!

        Activity

        jbonofre Jean-Baptiste Onofré added a comment -

        I'm not able to reproduce (and found any features XML with a namespace). I close this Jira, please reopen it with a test case if you reproduce it.

        jbonofre Jean-Baptiste Onofré added a comment -

        I tried the following (on Karaf 2.3.2-SNAPSHOT):

        • create the project using:
          mvn archetype:generate -DarchetypeGroupId=org.apache.karaf.archetypes -DarchetypeArtifactId=karaf-feature-archetype -DarchetypeVersion=2.3.2-SNAPSHOT -DgroupId=my.company -DartifactId=my.features -Dversion=1.0-SNAPSHOT -Dpackage=my.package
        • I updated the pom.xml to add a dependency

        The features.xml generated by the MOJO doesn't contain namespace. So I'm not able to reproduce the issue.


          People

          • Assignee:
            jbonofre Jean-Baptiste Onofré
            Reporter:
            nepster xuzhen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development