Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.3.1
    • Fix Version/s: 2.3.1
    • Component/s: karaf-core
    • Labels:
      None

      Description

      When trying to start Karaf minimal distribution:

      ERROR: Bundle org.apache.karaf.shell.console [14] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.console/2.3.1-SNAPSHOT (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console [14]: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0))))
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console [14]: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))
      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
      at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.karaf.shell.dev [15] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.dev/2.3.1-SNAPSHOT (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev [15]: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev [15]: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))]
      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
      at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.karaf.shell.commands [16] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.commands/2.3.1-SNAPSHOT (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.commands [16]: Unable to resolve 16.0: missing requirement [16.0] osgi.wiring.package; (&(osgi.wiring.package=jline)(version>=2.9.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.commands [16]: Unable to resolve 16.0: missing requirement [16.0] osgi.wiring.package; (&(osgi.wiring.package=jline)(version>=2.9.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))]
      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
      at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.karaf.features.command [18] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.command/2.3.1-SNAPSHOT (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.command [18]: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.command [18]: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))]
      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
      at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.karaf.shell.log [19] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.log/2.3.1-SNAPSHOT (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.log [19]: Unable to resolve 19.0: missing requirement [19.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.log [19]: Unable to resolve 19.0: missing requirement [19.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))]
      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
      at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.karaf.features.management [23] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.management/2.3.1-SNAPSHOT (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.management [23]: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.management [23]: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))]
      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
      at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.karaf.shell.packages [26] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.packages/2.3.1-SNAPSHOT (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages [26]: Unable to resolve 26.0: missing requirement [26.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages [26]: Unable to resolve 26.0: missing requirement [26.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))]
      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
      at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.karaf.shell.osgi [27] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.osgi/2.3.1-SNAPSHOT (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.osgi [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=jline)(version>=2.9.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.osgi [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=jline)(version>=2.9.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))]
      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
      at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.karaf.jaas.command [29] Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.command/2.3.1-SNAPSHOT (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.command [29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.command [29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)() not found.(version>=3.0.0)))]
      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
      at java.lang.Thread.run(Thread.java:662)

        Activity

        Show
        jbonofre Jean-Baptiste Onofré added a comment - Fixed on karaf-2.3.x: http://svn.apache.org/viewvc?view=revision&revision=1424903
        Hide
        jbonofre Jean-Baptiste Onofré added a comment -

        The problem is on the startup.properties: now the shell console depends on jaas authz bundle, but jaas authz is not defined in the minimal startup.properties.

        Show
        jbonofre Jean-Baptiste Onofré added a comment - The problem is on the startup.properties: now the shell console depends on jaas authz bundle, but jaas authz is not defined in the minimal startup.properties.

          People

          • Assignee:
            jbonofre Jean-Baptiste Onofré
            Reporter:
            jbonofre Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development