Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.3.2, 2.4.0, 3.0.0
    • Component/s: karaf-feature
    • Labels:
      None

      Issue Links

        Activity

        Hide
        Jean-Baptiste Onofré added a comment -

        spring-core 3.2.0.RELEASE is not an OSGi bundle (I don't know why, but it's a change comparing to Spring 3.0.x or 3.1.x).

        Anyway, Karaf 2.3.x should provide Spring 3.1.x support as well (currently, it only provides 3.0.x).

        I don't think that spring3.2 feature name is good, we can install a feature with his name and version. So Karaf can provide spring/3.2.0.RELEASE feature.

        I gonna dig why spring-core is not an OSGi bundle.

        Show
        Jean-Baptiste Onofré added a comment - spring-core 3.2.0.RELEASE is not an OSGi bundle (I don't know why, but it's a change comparing to Spring 3.0.x or 3.1.x). Anyway, Karaf 2.3.x should provide Spring 3.1.x support as well (currently, it only provides 3.0.x). I don't think that spring3.2 feature name is good, we can install a feature with his name and version. So Karaf can provide spring/3.2.0.RELEASE feature. I gonna dig why spring-core is not an OSGi bundle.
        Hide
        Hendy Irawan added a comment -

        +1 for this.

        I would also vote for Spring 3.2 be the default Spring for Karaf 2.4 and Karaf 3.0 (provided that the OSGi manifest problem is resolved).

        Show
        Hendy Irawan added a comment - +1 for this. I would also vote for Spring 3.2 be the default Spring for Karaf 2.4 and Karaf 3.0 (provided that the OSGi manifest problem is resolved).
        Show
        Hendy Irawan added a comment - Forum post: http://forum.springsource.org/showthread.php?129344-Spring-3-2-Milestone-1-and-OSGi-meta-data
        Hide
        Hendy Irawan added a comment -
        Show
        Hendy Irawan added a comment - Let's vote for https://jira.springsource.org/browse/SPR-9801 !
        Hide
        Hendy Irawan added a comment -

        Beginning with version 3.2, Spring Framework JAR files such as spring-core, spring-context, and spring-webmvc no longer contain MANIFEST.MF files with OSGi metadata. Likewise, builds are not automatically promoted to the SpringSource EBR.

        To ensure that OSGi users are able to upgrade to Spring Framework 3.2, SpringSource will create and publish bundles for Spring Framework 3.2 GA to the EBR in a separate process shortly following the GA release. At least one 3.2 milestone or release candidate will also be published such that the community can validate the OSGi metadata prior to going GA.

        Note that any future releases in the Spring Framework 3.1.x line will continue to contain OSGi metadata and will be published immediately to the EBR as per usual.

        Interested users may want to place a watch on SPR-8903 to be notified of further updates, e.g. when Spring Framework 3.2 bundles are published to the EBR.

        Show
        Hendy Irawan added a comment - Beginning with version 3.2, Spring Framework JAR files such as spring-core, spring-context, and spring-webmvc no longer contain MANIFEST.MF files with OSGi metadata. Likewise, builds are not automatically promoted to the SpringSource EBR. To ensure that OSGi users are able to upgrade to Spring Framework 3.2, SpringSource will create and publish bundles for Spring Framework 3.2 GA to the EBR in a separate process shortly following the GA release. At least one 3.2 milestone or release candidate will also be published such that the community can validate the OSGi metadata prior to going GA. Note that any future releases in the Spring Framework 3.1.x line will continue to contain OSGi metadata and will be published immediately to the EBR as per usual. Interested users may want to place a watch on SPR-8903 to be notified of further updates, e.g. when Spring Framework 3.2 bundles are published to the EBR.
        Hide
        Hendy Irawan added a comment -

        Greg Turnquist added a comment - 13/Dec/12 2:29 PM

        Finished publishing Spring Framework 3.2.0.RELEASE to the EBR.

        Show
        Hendy Irawan added a comment - Greg Turnquist added a comment - 13/Dec/12 2:29 PM Finished publishing Spring Framework 3.2.0.RELEASE to the EBR.
        Hide
        Ruslan added a comment -

        The issue of adding new Spring OSGi bundle is resoved by EBR-890 and new Spring Framework OSGi bundles (3.2.0.RELEASE as well as 3.2.1.RELEASE) are available at the SpringSource Enterprise Bundle Repository (EBR) .

        So, let's vote and wait for current issue resolving!

        Show
        Ruslan added a comment - The issue of adding new Spring OSGi bundle is resoved by EBR-890 and new Spring Framework OSGi bundles ( 3.2.0.RELEASE as well as 3.2.1.RELEASE ) are available at the SpringSource Enterprise Bundle Repository (EBR) . So, let's vote and wait for current issue resolving!
        Hide
        Ruslan added a comment -

        There is already released 2.3.1 of Apache Karaf and announced on Website, but the current
        issue in not there.

        In what Karaf versions are you planning to resolve this issue?

        P.S. See also SMX4-1337 issue.

        Show
        Ruslan added a comment - There is already released 2.3.1 of Apache Karaf and announced on Website , but the current issue in not there. In what Karaf versions are you planning to resolve this issue? P.S. See also SMX4-1337 issue.
        Hide
        Jean-Baptiste Onofré added a comment -

        I think we have another Jira about that with the fix version defined.

        Show
        Jean-Baptiste Onofré added a comment - I think we have another Jira about that with the fix version defined.
        Hide
        Ruslan added a comment - - edited
        1. Do you mean the KARAF-2185 with next fix in 3.0.0 version?
        2. Do you know if team of Apache ServiceMix also need support (upgrade) to Spring framework 3.2.x or they just base and reuse Karaf container release?
        Show
        Ruslan added a comment - - edited Do you mean the KARAF-2185 with next fix in 3.0.0 version ? Do you know if team of Apache ServiceMix also need support (upgrade) to Spring framework 3.2.x or they just base and reuse Karaf container release?
        Show
        Jean-Baptiste Onofré added a comment - Fixed on karaf-2.3.x: http://svn.apache.org/viewvc?view=revision&revision=1481748

          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Christian Müller
          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development