Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0.RC1
    • Fix Version/s: 3.0.0
    • Component/s: karaf-osgi
    • Labels:
      None

      Description

      i instal the features in karaf 3.0
      <?xml version="1.0" encoding="UTF-8"?>
      <features name="gemini-features">
      <feature name="gemini-blueprint-2" version="1.0.2.RELEASE">
      <bundle>mvn:org.eclipse.gemini/org.eclipse.gemini.blueprint.io/1.0.2.RELEASE</bundle>
      <bundle>mvn:org.eclipse.gemini/org.eclipse.gemini.blueprint.extender/1.0.2.RELEASE</bundle>
      <bundle>mvn:org.eclipse.gemini/org.eclipse.gemini.blueprint.core/1.0.2.RELEASE</bundle>
      </feature>
      </features>

      that exception :

      karaf@root()> Exception in thread "EclipseGeminiBlueprintExtenderThread-35" org.
      springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line 22 in XM
      L document from OSGi resource[bundle://79.0:0/OSGI-INF/blueprint/kar-deployer.xm
      l|bnd.id=79|bnd.sym=org.apache.karaf.deployer.kar] is invalid; nested exception
      is org.xml.sax.SAXParseException: cvc-complex-type.2.4.c: The matching wildcard
      is strict, but no declaration can be found for element 'ext:property-placeholder
      '.
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadB
      eanDefinitions(XmlBeanDefinitionReader.java:396)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBea
      nDefinitions(XmlBeanDefinitionReader.java:334)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBea
      nDefinitions(XmlBeanDefinitionReader.java:302)
      at org.springframework.beans.factory.support.AbstractBeanDefinitionReade
      r.loadBeanDefinitions(AbstractBeanDefinitionReader.java:174)
      at org.springframework.beans.factory.support.AbstractBeanDefinitionReade
      r.loadBeanDefinitions(AbstractBeanDefinitionReader.java:209)
      at org.springframework.beans.factory.support.AbstractBeanDefinitionReade
      r.loadBeanDefinitions(AbstractBeanDefinitionReader.java:180)
      at org.eclipse.gemini.blueprint.context.support.OsgiBundleXmlApplication
      Context.loadBeanDefinitions(OsgiBundleXmlApplicationContext.java:170)
      at org.eclipse.gemini.blueprint.context.support.OsgiBundleXmlApplication
      Context.loadBeanDefinitions(OsgiBundleXmlApplicationContext.java:140)
      at org.springframework.context.support.AbstractRefreshableApplicationCon
      text.refreshBeanFactory(AbstractRefreshableApplicationContext.java:131)
      at org.springframework.context.support.AbstractApplicationContext.obtain
      FreshBeanFactory(AbstractApplicationContext.java:527)
      at org.springframework.context.support.AbstractApplicationContext.refres
      h(AbstractApplicationContext.java:441)
      at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
      onApplicationContext.access$301(AbstractDelegatedExecutionApplicationContext.jav
      a:60)
      at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
      onApplicationContext$1.run(AbstractDelegatedExecutionApplicationContext.java:168
      )
      at org.eclipse.gemini.blueprint.util.internal.PrivilegedUtils.executeWit
      hCustomTCCL(PrivilegedUtils.java:85)
      at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
      onApplicationContext.normalRefresh(AbstractDelegatedExecutionApplicationContext.
      java:164)
      at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
      onApplicationContext$NoDependenciesWaitRefreshExecutor.refresh(AbstractDelegated
      ExecutionApplicationContext.java:78)
      at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
      onApplicationContext.refresh(AbstractDelegatedExecutionApplicationContext.java:1
      57)
      at org.eclipse.gemini.blueprint.extender.internal.activator.LifecycleMan
      ager$1.run(LifecycleManager.java:211)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: org.xml.sax.SAXParseException: cvc-complex-type.2.4.c: The matching w
      ildcard is strict, but no declaration can be found for element 'ext:property-pla
      ceholder'.
      at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAX
      ParseException(ErrorHandlerWrapper.java:195)
      at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.error(Err
      orHandlerWrapper.java:131)
      at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(
      XMLErrorReporter.java:384)
      at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(
      XMLErrorReporter.java:318)
      at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator$XSIErro
      rReporter.reportError(XMLSchemaValidator.java:423)
      at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.reportS
      chemaError(XMLSchemaValidator.java:3188)
      at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.handleS
      tartElement(XMLSchemaValidator.java:1933)
      at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.emptyEl
      ement(XMLSchemaValidator.java:731)
      at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scan
      StartElement(XMLNSDocumentScannerImpl.java:377)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImp
      l$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2756)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(X
      MLDocumentScannerImpl.java:647)
      at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next
      (XMLNSDocumentScannerImpl.java:140)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImp
      l.scanDocument(XMLDocumentFragmentScannerImpl.java:511)
      at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(X
      ML11Configuration.java:808)
      at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(X
      ML11Configuration.java:737)
      at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.
      java:119)
      at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.
      java:232)
      at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(Doc
      umentBuilderImpl.java:284)
      at org.springframework.beans.factory.xml.DefaultDocumentLoader.loadDocum
      ent(DefaultDocumentLoader.java:75)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadB
      eanDefinitions(XmlBeanDefinitionReader.java:388)
      ... 18 more

        Activity

        jbonofre Jean-Baptiste Onofré added a comment -

        The gemini support has been added in 3.0.0.RC1:

        http://svn.apache.org/repos/asf/karaf/trunk/assemblies/features/spring/src/main/feature/feature.xml

        The feature name is gemini-blueprint.

        So basicly, the new feature has been implemented. If we have an issue with this new feature another Jira should be created.

        tsmoon tsmoon added a comment -

        feature:install region
        i install the region feature .the exception:
        karaf@root()> Exception in thread "EclipseGeminiBlueprintExtenderThread-35" org.
        springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line 22 in XM
        L document from OSGi resource[bundle://79.0:0/OSGI-INF/blueprint/kar-deployer.xm
        l|bnd.id=79|bnd.sym=org.apache.karaf.deployer.kar] is invalid; nested exception
        is org.xml.sax.SAXParseException: cvc-complex-type.2.4.c: The matching wildcard
        is strict, but no declaration can be found for element 'ext:property-placeholder
        '.o
        at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadB
        eanDefinitions(XmlBeanDefinitionReader.java:396)
        at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBea
        nDefinitions(XmlBeanDefinitionReader.java:334)
        at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBea
        nDefinitions(XmlBeanDefinitionReader.java:302)
        at org.springframework.beans.factory.support.AbstractBeanDefinitionReade
        r.loadBeanDefinitions(AbstractBeanDefinitionReader.java:174)
        at org.springframework.beans.factory.support.AbstractBeanDefinitionReade
        r.loadBeanDefinitions(AbstractBeanDefinitionReader.java:209)
        at org.springframework.beans.factory.support.AbstractBeanDefinitionReade
        r.loadBeanDefinitions(AbstractBeanDefinitionReader.java:180)
        at org.eclipse.gemini.blueprint.context.support.OsgiBundleXmlApplication
        Context.loadBeanDefinitions(OsgiBundleXmlApplicationContext.java:170)
        at org.eclipse.gemini.blueprint.context.support.OsgiBundleXmlApplication
        Context.loadBeanDefinitions(OsgiBundleXmlApplicationContext.java:140)
        at org.springframework.context.support.AbstractRefreshableApplicationCon
        text.refreshBeanFactory(AbstractRefreshableApplicationContext.java:131)
        at org.springframework.context.support.AbstractApplicationContext.obtain
        FreshBeanFactory(AbstractApplicationContext.java:527)
        at org.springframework.context.support.AbstractApplicationContext.refres
        h(AbstractApplicationContext.java:441)
        s at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
        onApplicationContext.access$301(AbstractDelegatedExecutionApplicationContext.jav
        a:60)
        at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
        onApplicationContext$1.run(AbstractDelegatedExecutionApplicationContext.java:168
        )
        Exception in thread "EclipseGeminiBlueprintExtenderThread-2" at org.eclipse.g
        emini.blueprint.util.internal.PrivilegedUtils.executeWithCustomTCCL(PrivilegedUt
        ils.java:85)
        at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
        onApplicationContext.normalRefresh(AbstractDelegatedExecutionApplicationContext.
        java:164)
        at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
        onApplicationContext$NoDependenciesWaitRefreshExecutor.refresh(AbstractDelegated
        ExecutionApplicationContext.java:78)
        at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
        onApplicationContext.refresh(AbstractDelegatedExecutionApplicationContext.java:1
        57)
        at org.eclipse.gemini.blueprint.extender.internal.activator.LifecycleMan
        ager$1.run(LifecycleManager.java:211)
        at java.lang.Thread.run(Thread.java:662)
        Caused by: org.xml.sax.SAXParseException: cvc-complex-type.2.4.c: The matching w
        ildcard is strict, but no declaration can be found for element 'ext:property-pla
        ceholder'.
        at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAX
        ParseException(ErrorHandlerWrapper.java:195)
        at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.error(Err
        orHandlerWrapper.java:131)
        at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(
        XMLErrorReporter.java:384)
        at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(
        XMLErrorReporter.java:318)
        at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator$XSIErro
        rReporter.reportError(XMLSchemaValidator.java:423)
        at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.reportS
        chemaError(XMLSchemaValidator.java:3188)
        at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.handleS
        tartElement(XMLSchemaValidator.java:1933)
        at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.emptyEl
        ement(XMLSchemaValidator.java:731)
        at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scan
        StartElement(XMLNSDocumentScannerImpl.java:377)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImp
        l$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2756)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(X
        MLDocumentScannerImpl.java:647)
        at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next
        (XMLNSDocumentScannerImpl.java:140)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImp
        l.scanDocument(XMLDocumentFragmentScannerImpl.java:511)
        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(X
        ML11Configuration.java:808)
        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(X
        ML11Configuration.java:737)
        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.
        java:119)
        at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.
        java:232)
        at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(Doc
        umentBuilderImpl.java:284)
        at org.springframework.beans.factory.xml.DefaultDocumentLoader.loadDocum
        ent(DefaultDocumentLoader.java:75)
        at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadB
        eanDefinitions(XmlBeanDefinitionReader.java:388)g
        ... 18 more
        org.springframework.beans.factory.BeanCreationException: Error creating bean wit
        h name 'featureUrlHandlerRef': Invocation of init method failed; nested exceptio
        n is java.lang.IllegalArgumentException: invalid filter: url.handler.protocol=fe
        ature
        at org.springframework.beans.factory.support.AbstractAutowireCapableBean
        Factory.initializeBean(AbstractAutowireCapableBeanFactory.java:1455)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBean
        Factory.doCreateBean(AbstractAutowireCapableBeanFactory.java:519)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBean
        Factory.createBean(AbstractAutowireCapableBeanFactory.java:456)
        at org.springframework.beans.factory.support.AbstractBeanFactory$1.getOb
        ject(AbstractBeanFactory.java:294)
        at org.springframework.beans.factory.support.DefaultSingletonBeanRegistr
        y.getSingleton(DefaultSingletonBeanRegistry.java:225)
        at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBe
        an(AbstractBeanFactory.java:291)
        at org.springframework.beans.factory.support.AbstractBeanFactory.getBean
        (AbstractBeanFactory.java:193)
        at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBe
        an(AbstractBeanFactory.java:284)
        at org.springframework.beans.factory.support.AbstractBeanFactory.getBean
        (AbstractBeanFactory.java:193)
        at org.springframework.beans.factory.support.DefaultListableBeanFactory.
        preInstantiateSingletons(DefaultListableBeanFactory.java:591)
        at org.springframework.context.support.AbstractApplicationContext.finish
        BeanFactoryInitialization(AbstractApplicationContext.java:918)
        at org.springframework.context.support.AbstractApplicationContext.refres
        h(AbstractApplicationContext.java:469)
        at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
        onApplicationContext.access$301(AbstractDelegatedExecutionApplicationContext.jav
        a:60)
        at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
        onApplicationContext$1.run(AbstractDelegatedExecutionApplicationContext.java:168
        )
        at org.eclipse.gemini.blueprint.util.internal.PrivilegedUtils.executeWit
        hCustomTCCL(PrivilegedUtils.java:85)
        at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
        onApplicationContext.normalRefresh(AbstractDelegatedExecutionApplicationContext.
        java:164)
        at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
        onApplicationContext$NoDependenciesWaitRefreshExecutor.refresh(AbstractDelegated
        ExecutionApplicationContext.java:78)
        at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecuti
        onApplicationContext.refresh(AbstractDelegatedExecutionApplicationContext.java:1
        57)
        i at org.eclipse.gemini.blueprint.extender.internal.activator.LifecycleMan
        ager$1.run(LifecycleManager.java:211)
        at java.lang.Thread.run(Thread.java:662)
        Caused by: java.lang.IllegalArgumentException: invalid filter: url.handler.proto
        col=feature
        at org.eclipse.gemini.blueprint.util.OsgiFilterUtils.unifyFilter(OsgiFil
        terUtils.java:136)
        at org.eclipse.gemini.blueprint.util.OsgiFilterUtils.unifyFilter(OsgiFil
        terUtils.java:99)
        at org.eclipse.gemini.blueprint.util.OsgiFilterUtils.unifyFilter(OsgiFil
        terUtils.java:87)
        at org.eclipse.gemini.blueprint.service.importer.support.AbstractOsgiSer
        viceImportFactoryBean.getUnifiedFilter(AbstractOsgiServiceImportFactoryBean.java
        :109)
        at org.eclipse.gemini.blueprint.service.importer.support.AbstractOsgiSer
        viceImportFactoryBean.afterPropertiesSet(AbstractOsgiServiceImportFactoryBean.ja
        va:95)
        at org.eclipse.gemini.blueprint.service.importer.support.AbstractService
        ImporterProxyFactoryBean.afterPropertiesSet(AbstractServiceImporterProxyFactoryB
        ean.java:51)
        at org.eclipse.gemini.blueprint.service.importer.support.OsgiServiceProx
        yFactoryBean.afterPropertiesSet(OsgiServiceProxyFactoryBean.java:115)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBean
        Factory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1514)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBean
        Factory.initializeBean(AbstractAutowireCapableBeanFactory.java:1452)
        ... 19 more

        tsmoon tsmoon added a comment -

        what region feature?

        achim_nierbeck Achim Nierbeck added a comment -

        Did you also install the region feature?


          People

          • Assignee:
            Unassigned
            Reporter:
            tsmoon tsmoon
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development