Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.3.1
    • Component/s: karaf-shell
    • Labels:
      None

      Description

      When I made shutdown -f console hang

      1. Console.java.txt
        0.8 kB
        filippo balicchia

        Activity

        fbalicchia filippo balicchia added a comment -

        Please see the attach for the patch.

        jbonofre Jean-Baptiste Onofré added a comment -

        The patch doesn't look good to me.

        In fact, shutdown -f command doesn't really hang, it just waits for the enter key

        If you type enter on your keyboard, Karaf will shutdown correctly:

        karaf@root> shutdown -f
        karaf@root>

        jbonofre@vostro:~/workspace/karaf/karaf/assemblies/apache-karaf/target/apache-karaf-2.3.1-SNAPSHOT/bin$

        So, I gonna take a look on the command itself.

        jbonofre Jean-Baptiste Onofré added a comment -

        The problem is just an extra:

        reader.shutdown();

        in the console (which is not required).


          People

          • Assignee:
            jbonofre Jean-Baptiste Onofré
            Reporter:
            fbalicchia filippo balicchia
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development