Karaf
  1. Karaf
  2. KARAF-1911

Wrong version of camel-example-osgi in Getting Started/Quickstart Guide - 2.7.0 doesn't work

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.9
    • Fix Version/s: 2.2.10, 2.3.0
    • Component/s: karaf-documentation
    • Labels:
      None
    • Environment:

      OpenJDK 1.6.0_24

      Description

      I've just downloaded Apache Karaf 2.2.9 for linux and proceeded through Quick Start guide.

      I've typed:

      features:addurl mvn:org.apache.camel/camel-example-osgi/2.7.0/xml/features
      features:install camel-example-osgi

      And error is:

      Error executing command: Could not start bundle mvn:org.apache.camel/camel-spring/2.7.0 in feature(s) camel-spring-2.7.0: Uses constraint violation. Unable to resolve module org.apache.camel.camel-spring [79.0] because it is exposed to package 'org.springframework.core' from modules org.springframework.core [51.0] and org.springframework.core [65.0] via two dependency chains.

      Chain 1:
      org.apache.camel.camel-spring [79.0]
      import: (&(package=org.springframework.core)(version>=3.0.0)(!(version>=4.0.0)))

      export: package=org.springframework.core
      org.springframework.core [51.0]

      Chain 2:
      org.apache.camel.camel-spring [79.0]
      import: (&(package=org.springframework.osgi.context)(version>=1.2.0)(!(version>=2.0.0)))

      export: package=org.springframework.osgi.context; uses:=org.springframework.beans
      org.springframework.osgi.core [74.0]
      import: (&(package=org.springframework.beans)(version>=2.5.6)(!(version>=4.0.0)))

      export: package=org.springframework.beans; uses:=org.springframework.core
      org.springframework.beans [68.0]
      import: (&(package=org.springframework.core)(version>=3.0.7)(!(version>=3.0.8)))

      export: package=org.springframework.core
      org.springframework.core [65.0]

      It works with camel-example-osgi:2.6.0 version.

        Activity

        Robert Balent created issue -
        Robert Balent made changes -
        Field Original Value New Value
        Description I've just downloaded Apache Karaf 2.2.9 for linux and proceeded through Quick Start guide.

        I've typed:

        features:addurl mvn:org.apache.camel/camel-example-osgi/2.7.0/xml/features
        features:install camel-example-osgi


        And error is:

        Error executing command: Could not start bundle mvn:org.apache.camel/camel-spring/2.7.0 in feature(s) camel-spring-2.7.0: Uses constraint violation. Unable to resolve module org.apache.camel.camel-spring [79.0] because it is exposed to package 'org.springframework.core' from modules org.springframework.core [51.0] and org.springframework.core [65.0] via two dependency chains.

        Chain 1:
          org.apache.camel.camel-spring [79.0]
            import: (&(package=org.springframework.core)(version>=3.0.0)(!(version>=4.0.0)))
             |
            export: package=org.springframework.core
          org.springframework.core [51.0]

        Chain 2:
          org.apache.camel.camel-spring [79.0]
            import: (&(package=org.springframework.osgi.context)(version>=1.2.0)(!(version>=2.0.0)))
             |
            export: package=org.springframework.osgi.context; uses:=org.springframework.beans
          org.springframework.osgi.core [74.0]
            import: (&(package=org.springframework.beans)(version>=2.5.6)(!(version>=4.0.0)))
             |
            export: package=org.springframework.beans; uses:=org.springframework.core
          org.springframework.beans [68.0]
            import: (&(package=org.springframework.core)(version>=3.0.7)(!(version>=3.0.8)))
             |
            export: package=org.springframework.core
          org.springframework.core [65.0]


        It works with camel-example-osgi:2.6.0 version.
        I've just downloaded Apache Karaf 2.2.9 for linux and proceeded through Quick Start guide.

        I've typed:

        features:addurl mvn:org.apache.camel/camel-example-osgi/2.7.0/xml/features
        features:install camel-example-osgi


        And error is:

        Error executing command: Could not start bundle mvn:org.apache.camel/camel-spring/2.7.0 in feature(s) camel-spring-2.7.0: Uses constraint violation. Unable to resolve module org.apache.camel.camel-spring \[79.0\] because it is exposed to package 'org.springframework.core' from modules org.springframework.core \[51.0\] and org.springframework.core \[65.0\] via two dependency chains.

        Chain 1:
          org.apache.camel.camel-spring \[79.0\]
            import: (&(package=org.springframework.core)(version>=3.0.0)(!(version>=4.0.0)))
             |
            export: package=org.springframework.core
          org.springframework.core \[51.0\]

        Chain 2:
          org.apache.camel.camel-spring \[79.0\]
            import: (&(package=org.springframework.osgi.context)(version>=1.2.0)(!(version>=2.0.0)))
             |
            export: package=org.springframework.osgi.context; uses:=org.springframework.beans
          org.springframework.osgi.core \[74.0\]
            import: (&(package=org.springframework.beans)(version>=2.5.6)(!(version>=4.0.0)))
             |
            export: package=org.springframework.beans; uses:=org.springframework.core
          org.springframework.beans \[68.0\]
            import: (&(package=org.springframework.core)(version>=3.0.7)(!(version>=3.0.8)))
             |
            export: package=org.springframework.core
          org.springframework.core \[65.0\]


        It works with camel-example-osgi:2.6.0 version.
        Freeman Fang made changes -
        Assignee Freeman Fang [ ffang ]
        Freeman Fang added a comment -

        Hi,

        This isn't a Karaf issue, Karaf by default didn't install any spring bundle at all.
        This is caused by camel project feature pull in different spring version which cause conflict, this should be resolved in camel by tune the feature/bundle version range. Camel 2.7.0 is quite old and this issue I believe already get resolved for a long time, could you please try more recent camel version like 2.10.x?

        Anyway this isn't a Karaf issue.

        Freeman

        Freeman Fang made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]
        Robert Balent added a comment -

        So it's Karaf documentation issue and it should be changed in "Getting Started/Quick Start guide" to correct version. Can you please assign it to person which is responsible for this?

        Robert Balent made changes -
        Resolution Won't Fix [ 2 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Robert Balent added a comment -

        An I've also changed topic name.

        Robert Balent made changes -
        Summary Could not start bundle mvn:org.apache.camel/camel-spring/2.7.0 with Karaf 2.2.9 Wrong version of camel-example-osgi in Getting Started/Quickstart Guide - 2.7.0 doesn't work
        Component/s karaf-documentation [ 12313850 ]
        Robert Balent added a comment -

        And thank you for suggesting newer version, 2.10.1 works correctly.

        Regards,

        Robert

        Freeman Fang added a comment -

        I will update the wiki

        Robert Balent added a comment -

        Thank you very much.

        Freeman Fang added a comment -

        I've tested with camel 2.10 and it works, I'll update wiki accordingly, thanks for pointing out this issue.

        Freeman Fang added a comment -
        Freeman Fang made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Fix Version/s 2.2.10 [ 12322541 ]
        Fix Version/s 2.3.0 [ 12320554 ]
        Resolution Fixed [ 1 ]
        Gerd Bremer added a comment - - edited

        Did you really fix it? I just quick started and failed with version 2.7.0. Using 2.10.2 works fine.

        Update:
        The 'Getting Started' link on the home page http://karaf.apache.org/ points to

        http://karaf.apache.org/manual/latest-2.2.x/quick-start.html

        and not to

        http://karaf.apache.org/manual/latest-2.3.x/quick-start.html

        where the version is replaced. Maybe the link on the home page should be replaced?

        Freeman Fang added a comment -

        Hi,

        Yeah, I committed fix.
        However somehow the changed content in svn not get picked up by site. I'll ping around to see what happened.

        Freeman

        Tim Collins added a comment -

        This issue appears to have not been fixed.

        http://karaf.apache.org/manual/latest-2.2.x/quick-start.html

        I am using

        java version "1.7.0_09"
        Java(TM) SE Runtime Environment (build 1.7.0_09-b05)
        Java HotSpot(TM) 64-Bit Server VM (build 23.5-b02, mixed mode)

        and

        apache-karaf-2.3.0

        downloaded 2/14/2013

        As a newcomer and outsider and first-time Karaf user, I don't suppose I am entitled to an opinion, but I must admit to more than a little curiosity. The first example on the public web page seems to have been broken for months and nobody noticed nor fixed it? This seems mysterious to me.

        In case it benefits someone else, I am seeing this:

        karaf@root> features:addurl mvn:org.apache.camel/camel-example-osgi/2.7.0/xml/features
        karaf@root> features:install camel-example-osgi
        Error executing command: Could not start bundle mvn:org.apache.camel/camel-spring/2.7.0 in feature(s) camel-spring-2.7.0: Uses constraint violation. Unable to resolve bundle revision org.apache.camel.camel-spring [84.0] because it is exposed to package 'org.springframework.core' from bundle revisions org.springframework.core [55.0] and org.springframework.core [69.0] via two dependency chains.

        Chain 1:
        org.apache.camel.camel-spring [84.0]
        import: (&(osgi.wiring.package=org.springframework.core)(version>=3.0.0)(!(version>=4.0.0)))

        export: osgi.wiring.package=org.springframework.core
        org.springframework.core [55.0]

        Chain 2:
        org.apache.camel.camel-spring [84.0]
        import: (&(osgi.wiring.package=org.springframework.osgi.context)(version>=1.2.0)(!(version>=2.0.0)))

        export: osgi.wiring.package=org.springframework.osgi.context; uses:=org.springframework.beans
        org.springframework.osgi.core [78.0]
        import: (&(osgi.wiring.package=org.springframework.beans)(version>=2.5.6)(!(version>=4.0.0)))

        export: osgi.wiring.package=org.springframework.beans; uses:=org.springframework.core
        org.springframework.beans [72.0]
        import: (&(osgi.wiring.package=org.springframework.core)(version>=3.0.7)(!(version>=3.0.8)))

        export: osgi.wiring.package=org.springframework.core
        org.springframework.core [69.0]
        karaf@root>

        Robert Balent added a comment -

        Yes, I see, website isn't updated. Reopening issue.

        @Tim: Just use some new version of Camel and it will work. I've tried with 2.10.2 and it worked.

        Robert Balent made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Robert Balent added a comment -

        As Gerd correctly mentioned there is wrong link on the home page.

        Freeman Fang added a comment -

        change site navigation "Getting Started" to point karaf 2.3.x
        http://svn.apache.org/viewvc?view=revision&revision=r1447590
        hopefully the site get updated soon

        Freeman Fang added a comment -

        The change is picked up by the website now

        Freeman Fang made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        27m 40s 1 Freeman Fang 11/Oct/12 09:36
        Resolved Resolved Reopened Reopened
        127d 4m 2 Robert Balent 15/Feb/13 08:58
        Reopened Reopened Resolved Resolved
        27d 18h 43m 2 Freeman Fang 15/Mar/13 03:24

          People

          • Assignee:
            Freeman Fang
            Reporter:
            Robert Balent
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development