Karaf
  1. Karaf
  2. KARAF-1850

feature:list should use alphabetical order

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.10, 2.3.0, 3.0.0
    • Component/s: karaf-shell
    • Labels:
      None

      Description

      currently karaf webconsole list features in alphabetical order by default;

      it would help if karaf shell console would do the same;

      as it seems random order now:

      Name | Version | Installed | Repository | Description
      --------------------------------------------------------------------------------------------------------------------------------------------------------------
      standard | 3.0.0-SNAPSHOT | x | standard-3.0.0-SNAPSHOT | Karaf standard feature
      aries-annotation | 3.0.0-SNAPSHOT | | standard-3.0.0-SNAPSHOT | Aries Annotations
      wrapper | 3.0.0-SNAPSHOT | | standard-3.0.0-SNAPSHOT | Provide OS integration
      obr | 3.0.0-SNAPSHOT | | standard-3.0.0-SNAPSHOT | Provide OSGi Bundle Repository (OBR) support
      config | 3.0.0-SNAPSHOT | x | standard-3.0.0-SNAPSHOT | Provide OSGi ConfigAdmin support
      region | 3.0.0-SNAPSHOT | | standard-3.0.0-SNAPSHOT | Provide Region Support
      jetty | 8.1.5.v20120716 | x | standard-3.0.0-SNAPSHOT | Provide Jetty engine support
      package | 3.0.0-SNAPSHOT | | standard-3.0.0-SNAPSHOT | Package commands and mbeans
      http | 3.0.0-SNAPSHOT | x | standard-3.0.0-SNAPSHOT | Implementation of the OSGI HTTP Service
      http-whiteboard | 3.0.0-SNAPSHOT | | standard-3.0.0-SNAPSHOT | Provide HTTP Whiteboard pattern support
      war | 3.0.0-SNAPSHOT | | standard-3.0.0-SNAPSHOT | Turn Karaf as a full WebContainer
      kar | 3.0.0-SNAPSHOT | | standard-3.0.0-SNAPSHOT | Provide KAR (KARaf archive) support
      webconsole | 3.0.0-SNAPSHOT | x | standard-3.0.0-SNAPSHOT | Base support of the Karaf WebConsole
      ssh | 3.0.0-SNAPSHOT | x | standard-3.0.0-SNAPSHOT | Provide a SSHd server on Karaf
      management | 3.0.0-SNAPSHOT | x | standard-3.0.0-SNAPSHOT | Provide a JMX MBeanServer and a set of MBeans in Karaf
      scheduler | 3.0.0-SNAPSHOT | | standard-3.0.0-SNAPSHOT | Provide a scheduler service in Karaf to fire events
      eventadmin | 3.0.0-SNAPSHOT | x | standard-3.0.0-SNAPSHOT | OSGi Event Admin service specification for event-based communication
      jasypt-encryption | 3.0.0-SNAPSHOT | | standard-3.0.0-SNAPSHOT | Advanced encryption support for Karaf security
      scr | 3.0.0-SNAPSHOT | x | standard-3.0.0-SNAPSHOT | Declarative Service support
      transaction | 1.0.0 | | enterprise-3.0.0-SNAPSHOT | OSGi Transaction Manager
      jpa | 1.0.0 | | enterprise-3.0.0-SNAPSHOT | OSGi Persistence Container
      jndi | 1.0.0 | | enterprise-3.0.0-SNAPSHOT | OSGi Service Registry JNDI access
      application-without-isolation | 1.0.0 | | enterprise-3.0.0-SNAPSHOT | Provide EBA archive support
      andrei2@root()>

        Activity

        Freeman Fang added a comment -

        we can introduce another option which specify to use alphabetical order.
        Btw, this should be an improvement but not a bug

        Jean-Baptiste Onofré added a comment -

        Fully agree with Freeman:
        1/ it's an improvement, not a bug
        2/ agree to introduce an option for that

        Andrei Pozolotin added a comment -

        thank you.


          People

          • Assignee:
            Freeman Fang
            Reporter:
            Andrei Pozolotin
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development