Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3.0, 3.0.0
    • Component/s: None
    • Labels:
      None

      Description

      currently karaf endorse jaxws api jar, which need use javax.xml.soap package, this package could be from jdk or from saaj-api bundle jar. However, as we endorse jaxws api, so jaxws class javax.xml.ws.soap.SOAPFaultException will always load
      javax.xml.soap.SOAPFault from boot classloader, so that if customer bundle import-package javax.xml.soap from saaj-api bundle, then customer easily run into exception like
      Caused by: java.lang.LinkageError: loader constraint violation: loader (instance of <bootloader>) previously initiated loading for a different type with name "javax/xml/soap/SOAPFault"
      at javax.xml.ws.soap.SOAPFaultException.<init>(SOAPFaultException.java:28)

      We should also endorse saaj-api jar and in jre.properties let system bundle 0 export javax.xml.soap;version="1.3".

        Activity


          People

          • Assignee:
            Freeman Fang
            Reporter:
            Freeman Fang
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development