Karaf
  1. Karaf
  2. KARAF-1834

Make KarafTestSupport available externally

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3.0, 3.0.0
    • Component/s: None
    • Labels:
      None

      Description

      Currently the org.apache.karaf.itests KarafTestSupportjava class is inside the test package and therefore not exported by maven. It would be useful to use the executeCommand methods for junit tests

        Activity

        Alan Foster added a comment -

        Freeman Fang Thanks for this. That's a very nice solution, I didn't know you could do that! I thought the only solution was to restructure the package, this is why I didn't attempt the patch myself!

        Sorry for raising this Jira under the wrong type, I'll make sure to specify it correctly next time

        Alan

        Freeman Fang added a comment -

        BTW this should be an improvement but not a bug

        Freeman Fang added a comment -

        Hi,

        We can publish the test-jar also, afterwards you can add dependency like

        <dependency>
          <groupId>org.apache.karaf.itests</groupId>
           <artifactId>itests</artifactId>
          <version>{version}</version>
          <type>test-jar</type>
          <scope>test</scope>
        </dependency>
        

        to use KarafTestSupport


          People

          • Assignee:
            Freeman Fang
            Reporter:
            Alan Foster
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development