Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.9, 2.3.0
    • Component/s: None
    • Labels:
      None

      Description

      The karaf-2.3.x and karaf-2.2.x branches Jenkins builds are failed due to demo issue:

      [INFO] Error deploying artifact: Authorization failed: Access denied to: https://repository.apache.org/service/local/staging/deploy/maven2/org/apache/karaf/demos/deployer/wrap/osgi.commons-lang/2.4/osgi.commons-lang-2.4.jar

      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.lifecycle.LifecycleExecutionException: Error deploying artifact: Authorization failed: Access denied to: https://repository.apache.org/service/local/staging/deploy/maven2/org/apache/karaf/demos/deployer/wrap/osgi.commons-lang/2.4/osgi.commons-lang-2.4.jar
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:719)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      at org.apache.maven.lifecycle.LifecycleExecutorInterceptor.execute(LifecycleExecutorInterceptor.java:65)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:592)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at hudson.maven.agent.Main.launch(Main.java:185)
      at hudson.maven.MavenBuilder.call(MavenBuilder.java:151)
      at hudson.maven.Maven2Builder.call(Maven2Builder.java:77)
      at hudson.maven.Maven2Builder.call(Maven2Builder.java:53)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:651)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:676)
      at java.lang.Thread.run(Thread.java:595)

        Activity

        Jean-Baptiste Onofré added a comment -

        The problem is that it uses the staging repository instead of the snapshot one:

        [INFO] — maven-deploy-plugin:2.7:deploy (default-deploy) @ osgi.commons-lang —
        Uploading: https://repository.apache.org/service/local/staging/deploy/maven2/org/apache/karaf/demos/deployer/wrap/osgi.commons-lang/2.4/osgi.commons-lang-2.4.jar

        Jean-Baptiste Onofré added a comment -

        OK, it's "normal" as the version is not correct: we should use a SNAPSHOT version (even if we wrap a released version). I think it's not a big deal to have Karaf versioning in the demo deployer wrap.


          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development