Karaf
  1. Karaf
  2. KARAF-1487

Bundles in deploy are deployed before startup process had been finished

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.7
    • Fix Version/s: 2.3.2, 2.4.0, 3.0.0
    • Component/s: karaf-core
    • Labels:
      None

      Description

      I'm not sure, but I assume that this also affects the master. This needs to be evaluated after a fix had been crafted.

      To reproduce the issue download and unpack karaf-2.2.7; then add the attached jar to the deploy folder (which is basically [1] packed with tinybundles). Now, BEFORE starting karaf, edit etc/org.apache.karaf.features.cfg and add "war" to the bootFeatures. Now start Karaf. you see that the deploy folder bundle had been deployed BEFORE the war feature had been started. Therefore the bundle is missing some packages and is not refreshed as the new feature is available. When you refresh the bundle now manually it works.

      [1] https://github.com/openengsb/labs-paxexam-karaf/tree/master/regression/src/test/java/org/openengsb/labs/paxexam/karaf/regression/supports

        Activity

        Andreas Pieber added a comment -

        File to deploy

        Jamie goodyear added a comment -

        Bumping out to 2.2.9.

        Christian Schneider added a comment -

        I think this is not a bug. The ServletActivator should react on the HttpServlet coming up and then register its servlet. You can probably produce a similar problem with the above jar by installing it correctly and then uninstall and reinstall the war feature. The servlet will then disappear and not come back again. If you track the HttpService the above use case would work.

        Jean-Baptiste Onofré added a comment -

        It should be better now with the boot features installed in sync mode.


          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Andreas Pieber
          • Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development