Karaf
  1. Karaf
  2. KARAF-1278

Comands: History does not work, can not edit current comand

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.2.6, 2.3.0, 3.0.0
    • Fix Version/s: 2.2.11, 2.3.1, 3.0.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows 7

      Description

      Can not list history commands using Up and Down arrow buttons.
      Can not edit current command using Left arrow button, only Backspace to delete the end of command.

        Issue Links

          Activity

          Michał Chudy added a comment -

          I'm having the same issue on Karaf 3.0.1 on Windows 7. It's terribly annoying.

          Lukasz Tymoszczuk added a comment - - edited

          I don't have win7.

          I've found simple workaround: use numerical arrows (8, 4, 2, 6) num lock has to be off)

          Jean-Baptiste Onofré added a comment -

          Lukasz, do you have a Win7 to try to reproduce ?

          Lukasz Tymoszczuk added a comment - - edited

          I reproduced it with Karaf 2.3.2 on Win 8, same result as Alexey:
          up arrow:
          karaf@root> ÓH
          down arrow:
          karaf@root> ÓHÓP

          Jean-Baptiste Onofré added a comment -

          Tested on Windows 7 Pro, x86_64, (EN locale) without problem with:

          • Karaf 3.0.0-SNAPSHOT (trunk)
          • Karaf 2.3.1-SNAPSHOT
          • Karaf 2.2.11-SNAPSHOT

          All this SNAPSHOTs use jline 2.9.

          Jean-Baptiste Onofré added a comment -

          The problem is not there with Karaf 2.3.1-SNAPSHOT on Windows 7 (x64). I'm testing with latest Karaf 2.2.11-SNAPSHOT and 3.0.0-SNAPSHOT.

          Barak added a comment -

          This issue exists on version 2.2.6-2.2.9.
          Any idea what is going on?

          Shravan Pabba added a comment -

          Need history and current command edit

          Barak added a comment -

          Any progress here? Losing history is a real pain.

          Alexey Markevich added a comment -

          As workaround there are additional key combinations:
          http://cnswww.cns.cwru.edu/php/chet/readline/readline.html#SEC15

          Barak added a comment -

          +1 - no History and can't edit commands on Windows 7

          Alexey Markevich added a comment -

          Karaf 2.2.6, Win 2003 x64:
          key up:
          karaf@root> рH
          key down:
          karaf@root> рP
          key left
          karaf@root> рK
          key right:
          karaf@root> рM
          Esc don't clear input; double escape cause:
          karaf@root> Display all 227 possibilities? (y or n)

          Jean-Baptiste Onofré added a comment -

          I confirmed, I reproduced on Windows 7. I'm digging on JLine 2.6.

          Jean-Baptiste Onofré added a comment -

          I'm starting a Windows 7 vm.

          Jean-Baptiste Onofré added a comment -

          On Linux, with Karaf 2.2.6-SNAPSHOT:

          • up/down arrow keys work fine, I can navigate in the history
          • left/right arrow keys work fine to "edit" the current command
          • backspace/delete keys work fine too

          The only "Home/End" keys don't work as expected.


            People

            • Assignee:
              Jean-Baptiste Onofré
              Reporter:
              Roman Minko
            • Votes:
              6 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development