Karaf
  1. Karaf
  2. KARAF-1260

Karaf 2.2.x branch - Console doesn't like it when the console window is to small - no line wrapping for commands

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.1.3
    • Fix Version/s: 2.2.6
    • Component/s: karaf-shell
    • Labels:
      None
    • Environment:

      Windows, maybe ssh (putty on windows) too

      Description

      On a 80 character console not all commands can be executed in a single line.
      E.g. osgi:install file:<lengthy-fullpath-tobundle>/bundle/version

        Issue Links

          Activity

          Jamie goodyear created issue -
          Jamie goodyear made changes -
          Field Original Value New Value
          Link This issue is a clone of KARAF-479 [ KARAF-479 ]
          Jamie goodyear added a comment -

          Cloned issue.

          The issue is resolved for 3.0.x branch, but remains for 2.2.x.

          Jamie goodyear made changes -
          Fix Version/s 2.2.6 [ 12319142 ]
          Fix Version/s 3.0.0 [ 12316040 ]
          Jamie goodyear added a comment -

          2.2.6-SNAPSHOT Still contains this behaviour.

          Jean-Baptiste Onofré added a comment -

          On trunk, to fix that I upgraded to the latest Jline version (2.6) and jansi (1.8).

          Currently, on karaf-2.2.x, we use jline 2.5 and jansi 1.7.

          As it's minor udpate, and that we can fix this issue with this update, I will update also on the branch.

          Jean-Baptiste Onofré made changes -
          Assignee Christian Schneider [ chris@die-schneider.net ] Jean-Baptiste Onofré [ jbonofre ]
          Jean-Baptiste Onofré made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Jamie goodyear made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          4h 36m 1 Jean-Baptiste Onofré 12/Mar/12 18:26
          Resolved Resolved Closed Closed
          27d 15h 5m 1 Jamie goodyear 09/Apr/12 10:31

            People

            • Assignee:
              Jean-Baptiste Onofré
              Reporter:
              Jamie goodyear
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development