Uploaded image for project: 'Karaf'
  1. Karaf
  2. KARAF-1162

A command that can not be loaded breaks the whole completion

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.8, 2.3.0, 3.0.0
    • Component/s: None
    • Labels:
      None

      Description

      
      org.osgi.service.blueprint.container.ComponentDefinitionException: Unable to load class org.apache.felix.framework.monitor.MonitoringService from recipe ReferenceRecipe[name='monitoringService']
      	at org.apache.aries.blueprint.container.AbstractServiceReferenceRecipe.loadType(AbstractServiceReferenceRecipe.java:227)
      	at org.apache.aries.blueprint.di.AbstractRecipe.loadClass(AbstractRecipe.java:97)
      	at org.apache.aries.blueprint.container.AbstractServiceReferenceRecipe.getInterfaceClass(AbstractServiceReferenceRecipe.java:289)
      	at org.apache.aries.blueprint.container.ReferenceRecipe.internalCreate(ReferenceRecipe.java:79)
      	at org.apache.aries.blueprint.di.AbstractRecipe.create(AbstractRecipe.java:64)
      	at org.apache.aries.blueprint.di.RefRecipe.internalCreate(RefRecipe.java:60)
      	at org.apache.aries.blueprint.di.AbstractRecipe.create(AbstractRecipe.java:64)
      	at org.apache.aries.blueprint.container.BeanRecipe.setProperty(BeanRecipe.java:813)
      	at org.apache.aries.blueprint.container.BeanRecipe.setProperties(BeanRecipe.java:787)
      	at org.apache.aries.blueprint.container.BeanRecipe.setProperties(BeanRecipe.java:768)
      	at org.apache.aries.blueprint.container.BeanRecipe.internalCreate(BeanRecipe.java:722)
      	at org.apache.aries.blueprint.di.AbstractRecipe.create(AbstractRecipe.java:64)
      	at org.apache.aries.blueprint.container.BlueprintRepository.createInstances(BlueprintRepository.java:219)
      	at org.apache.aries.blueprint.container.BlueprintRepository.createInstance(BlueprintRepository.java:198)
      	at org.apache.aries.blueprint.container.BlueprintRepository.create(BlueprintRepository.java:137)
      	at org.apache.aries.blueprint.container.BlueprintContainerImpl.getComponentInstance(BlueprintContainerImpl.java:721)
      	at org.apache.karaf.shell.console.commands.BlueprintCommand.createNewAction(BlueprintCommand.java:83)
      	at org.apache.felix.gogo.commands.basic.AbstractCommand.getActionClass(AbstractCommand.java:45)
      	at org.apache.karaf.shell.console.completer.ArgumentCompleter.<init>(ArgumentCompleter.java:70)
      	at org.apache.karaf.shell.console.completer.CommandsCompleter.checkData(CommandsCompleter.java:78)
      	at org.apache.karaf.shell.console.completer.CommandsCompleter.complete(CommandsCompleter.java:55)
      	at org.apache.karaf.shell.console.jline.CompleterAsCompletor.complete(CompleterAsCompletor.java:32)
      	at jline.console.ConsoleReader.complete(ConsoleReader.java:1462)
      	at jline.console.ConsoleReader.readLine(ConsoleReader.java:1220)
      	at jline.console.ConsoleReader.readLine(ConsoleReader.java:1078)
      	at org.apache.karaf.shell.console.jline.Console.run(Console.java:191)
      	at java.lang.Thread.run(Thread.java:680)
      Caused by: java.lang.ClassNotFoundException: org.apache.felix.framework.monitor.MonitoringService not found by org.apache.karaf.shell.dev2 [12]
      	at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:845)
      	at org.apache.felix.framework.ModuleImpl.access$400(ModuleImpl.java:74)
      	at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1840)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      	at org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:703)
      	at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1630)
      	at org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:909)
      	at org.apache.aries.blueprint.container.BlueprintContainerImpl.loadClass(BlueprintContainerImpl.java:387)
      	at org.apache.aries.blueprint.container.GenericType.parse(GenericType.java:115)
      	at org.apache.aries.blueprint.container.AbstractServiceReferenceRecipe.loadType(AbstractServiceReferenceRecipe.java:225)
      	... 26 more
      

        Activity

        jgoodyear Jamie goodyear added a comment -

        We'd like to cut an RC of Karaf 2.2.7 as soon as possible once the File Install issue has been resolved. I'd like to bump this issue out to 2.2.8 unless you believe you'll have a fix in before that time.

        jgoodyear Jamie goodyear added a comment -

        Hi Guillaume,

        We're looking at performing a 2.2.8 RC in the near term, could you update us with this issues' status? Many Thanks.

        Cheers,
        Jamie

        gnt Guillaume Nodet added a comment -

        Fixed in rev 1349658, 1349659 and 1349660


          People

          • Assignee:
            gnt Guillaume Nodet
            Reporter:
            gnt Guillaume Nodet
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development