Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Many of the dependencies that Kafka 0.8 uses are old. It would be a good idea to upgrade all of these where possible.

      log4j is set to 1.2.15, but the latest is 1.2.17
      zookeeper is at 3.3.4, , there is 3.3.6 (August 2012), and 3.4.5 (Nov 2012. 3.4.x includes several major enhancements and fixes over the 3.3.x line.
      org.slf4j is at 1.6.4, there is 1.6.6 (June 2012) and 1.7.5 (March 2013)
      net.sf.jopt-simple is at 3.2, there is 3.3 (May 2011) and 4.4 (Jan 2013)

        Attachments

        1. KAFKA-854.patch
          23 kB
          Scott Carey
        2. KAFKA-854.patch
          20 kB
          Scott Carey
        3. KAFKA-854.patch
          22 kB
          Scott Carey
        4. 0001-KAFKA-854-Upgrade-Deps-to-latest.patch
          6 kB
          Matt Christiansen

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                scott_carey Scott Carey
              • Votes:
                0 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: