Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-826

Make Kafka 0.8 depend on metrics 2.2.0 instead of 3.x

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 0.8.0
    • Component/s: core

      Description

      In order to mavenize Kafka 0.8, we have to depend on metrics 2.2.0 since metrics 3.x is a huge change as well as not an officially supported release.

        Attachments

        1. kafka-fix-for-826-complete.patch
          15 kB
          Dragos Manolescu
        2. kafka-fix-for-826-take2.patch
          9 kB
          Dragos Manolescu
        3. kafka-fix-for-826.patch
          9 kB
          Dragos Manolescu

          Issue Links

            Activity

              People

              • Assignee:
                dragosm Dragos Manolescu
                Reporter:
                nehanarkhede Neha Narkhede
              • Votes:
                0 Vote for this issue
                Watchers:
                12 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: