The rebased patch does not really comment on/address the concern in the original review - i.e., it breaks a relatively clean
and convenient syntax in the common case (of updating a single timer) to support updates to multiple timers. It's obviously
not a particularly major issue, but a rung higher than say, a debate over whitespace/coding style. My only point is that we
should try and avoid making a change that goes from a nice syntax to a rather inconvenient syntax. For that reason, I'm
more in favor of the change to KafkaTimer in
That said, how about the following: both these patches need multiple timer updates to update an aggregate timer as well
as a specific timer - i.e., up to this point we don't really have a use case for updating more than two timers simultaneously.
So we can accomplish this case with the following:
and avoid any change to KafkaTimer. Does that seem reasonable to you guys?