Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-5977

Upgrade RocksDB dependency to legally acceptable version

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.10.0.0
    • Fix Version/s: 1.0.0
    • Component/s: streams
    • Labels:
      None

      Description

      RocksDB 5.5.5+ seems to be legally acceptable. For more info see

      Even latest trunk of Apache Kafka depends on older RocksDB https://github.com/apache/kafka/blob/trunk/gradle/dependencies.gradle#L67

      If I'm not mistaken, this makes all current Apache Kafka 0.10+ releases not legally acceptable Apache products.

      Please consider upgrading the dependency. If possible please include the change in Apache Kafka 1.0.0 release, if not also in patch releases of older still supported 0.x Apache Kafka branches.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                guozhang Guozhang Wang
                Reporter:
                sslavic Stevo Slavić
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: