Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-4257

Inconsistencies in 0.10.1 upgrade docs

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.10.1.0
    • Fix Version/s: 0.10.1.0
    • Component/s: documentation
    • Labels:
      None

      Description

      There are several inconsistencies in the 0.10.1.0 upgrade docs that make it difficult to determine what client versions are compatible with what broker versions.

      The initial heading in the upgrade docs is "Upgrading from 0.10.0.X to 0.10.1.0", but it includes clauses about versions prior to 0.10. Is the intention for these instructions to be valid for upgrading from brokers as far back as 0.8? Should this section simply be called "Upgrading to 0.10.1.0"?

      I cannot tell from the docs whether I can upgrade to 0.10.1.0 clients on top of 0.10.0.X brokers. In particular, step 5 of the upgrade instructions mentions "Once all consumers have been upgraded to 0.10.0". Should that read 0.10.1, or is the intention here truly that clients on 9.X or below need to be at version 0.10.0.0 at a minimum?

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              jeff.klukas@gmail.com Jeff Klukas
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: