Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-3633

Kafka Consumer API breaking backward compatibility

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: 0.10.0.0
    • Component/s: None
    • Labels:
      None

      Description

      KAFKA-2991 and KAFKA-3006 broke the backward compatibility. In storm we already using 0.9.0.1 consumer api for the KafkaSpout. We should atleast kept the older methods and shouldn't be breaking backward compatibility.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                sriharsha Sriharsha Chintalapani
                Reporter:
                sriharsha Sriharsha Chintalapani
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: