Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-1927 Replace requests in kafka.api with requests in org.apache.kafka.common.requests
  3. KAFKA-2195

Add versionId to AbstractRequest.getErrorResponse and AbstractRequest.getRequest

    XMLWordPrintableJSON

Details

    • Sub-task
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 0.9.0.0
    • None
    • None

    Description

      This is needed to support versioning.
      1) getRequest: to parse bytes into correct schema you need to know it's version; by default it's the latest version (current_schema)

      2) getErrorResponse: after filling map with error codes you need to create respective Response message which dependes on versionId

      Attachments

        1. KAFKA-2195_2015-06-16_22:28:19.patch
          66 kB
          Andrii Biletskyi
        2. KAFKA-2195_2015-06-15_09:54:53.patch
          55 kB
          Andrii Biletskyi
        3. KAFKA-2195_2015-05-24_22:48:55.patch
          49 kB
          Andrii Biletskyi
        4. KAFKA-2195.patch
          28 kB
          Andrii Biletskyi

        Issue Links

          Activity

            People

              abiletskyi Andrii Biletskyi
              abiletskyi Andrii Biletskyi
              Jun Rao Jun Rao
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: