Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.2.0
    • Fix Version/s: 0.8.2.0
    • Component/s: None
    • Labels:
      None

      Description

      All unit tests are disabled since they hang transiently (see details in KAFKA-1391).

      1. KAFKA-1397_2014-04-28_14:48:32.patch
        57 kB
        Timothy Chen
      2. KAFKA-1397_2014-04-28_17:08:49.patch
        64 kB
        Timothy Chen
      3. KAFKA-1397_2014-04-30_14:55:28.patch
        58 kB
        Timothy Chen
      4. KAFKA-1397_2014-05-01_15:53:57.patch
        55 kB
        Timothy Chen
      5. KAFKA-1397_2014-05-01_18:12:24.patch
        64 kB
        Timothy Chen
      6. KAFKA-1397_2014-05-02_13:38:02.patch
        58 kB
        Timothy Chen
      7. KAFKA-1397_2014-05-05_11:17:59.patch
        58 kB
        Timothy Chen
      8. KAFKA-1397_2014-05-05_14:00:29.patch
        59 kB
        Timothy Chen
      9. KAFKA-1397.patch
        57 kB
        Timothy Chen

        Issue Links

          Activity

          Jim Plush added a comment -

          what was the regression that caused topic deletion to stop working?

          Jun Rao added a comment -

          The original implementation never fully worked.

          Timothy Chen added a comment -

          Created reviewboard https://reviews.apache.org/r/20745/
          against branch origin/trunk

          Neha Narkhede added a comment -

          Timothy Chen Can you please explain the issue that your patch attempts to fix? I couldn't find anything on the JIRA or reviewboard.

          Timothy Chen added a comment -

          Updated reviewboard https://reviews.apache.org/r/20745/
          against branch origin/trunk

          Timothy Chen added a comment -

          Updated reviewboard https://reviews.apache.org/r/20745/
          against branch origin/trunk

          Timothy Chen added a comment -

          Updated reviewboard https://reviews.apache.org/r/20745/
          against branch origin/trunk

          Timothy Chen added a comment -

          Updated reviewboard https://reviews.apache.org/r/20745/
          against branch origin/trunk

          Timothy Chen added a comment -

          Updated reviewboard https://reviews.apache.org/r/20745/
          against branch origin/trunk

          Timothy Chen added a comment -

          Updated reviewboard https://reviews.apache.org/r/20745/
          against branch origin/trunk

          Timothy Chen added a comment -

          Updated reviewboard https://reviews.apache.org/r/20745/
          against branch origin/trunk

          Timothy Chen added a comment -

          Updated reviewboard https://reviews.apache.org/r/20745/
          against branch origin/trunk

          Jun Rao added a comment -

          Thanks for the patch. +1 and committed to trunk.

          Stefan Miklosovic added a comment -

          I am not sure what I am doing wrong but it seems to me this does not work in 0.8.2.1

          I am doing this

          $ bin/zookeeper-server-start.sh config/zookeeper.properties
          $ bin/kafka-server-start.sh config/server.properties
          $ bin/kafka-topics.sh --zookeeper 127.0.0.1:2181 --create --topic someTopic --partitions 10 --replication-factor 1
          $ bin/kafka-topics.sh --list // gives me "someTopic"
          $ bin/kafka-topics.sh --zookeeper 127.0.0.1:2181 --delete --topic someTopic
          $ bin/kafka-topics.sh --list // gives me "someTopic - marked for deletion"

          and this is there forever, even when I stop broker and zookeeper and start it once again, nothing changes, it is there forever.

          I set delete.topics.enable=true in server.properties for broker

          Sriharsha Chintalapani added a comment -

          Stefan Miklosovic
          It looks like you are setting the wrong property , its not "delete.topics.enable" . Can you try setting "delete.topic.enable" (topic is not plural) to true

          Stefan Miklosovic added a comment -

          Yes it is "delete.topic.enable", that was my typo in the original post, the behaviour is the same. Could you confirm this?

          Sriharsha Chintalapani added a comment -

          Stefan Miklosovic I did a quick test on a single kafka 0.8.2.1 . I am not able to reproduce this it takes a bit of time but the topic gets deleted.
          Just to check make sure you don't have any producer or consumer sending any requests while the delete topic is going on or just set auto.creation.topic.enable to false in server.properties

          ./bin/kafka-topics.sh --zookeeper localhost:2181 --describe --topic test-topic
          Topic:test-topic PartitionCount:10 ReplicationFactor:1 Configs:
          Topic: test-topic Partition: 0 Leader: 0 Replicas: 0 Isr: 0
          Topic: test-topic Partition: 1 Leader: 0 Replicas: 0 Isr: 0
          Topic: test-topic Partition: 2 Leader: 0 Replicas: 0 Isr: 0
          Topic: test-topic Partition: 3 Leader: 0 Replicas: 0 Isr: 0
          Topic: test-topic Partition: 4 Leader: 0 Replicas: 0 Isr: 0
          Topic: test-topic Partition: 5 Leader: 0 Replicas: 0 Isr: 0
          Topic: test-topic Partition: 6 Leader: 0 Replicas: 0 Isr: 0
          Topic: test-topic Partition: 7 Leader: 0 Replicas: 0 Isr: 0
          Topic: test-topic Partition: 8 Leader: 0 Replicas: 0 Isr: 0
          Topic: test-topic Partition: 9 Leader: 0 Replicas: 0 Isr: 0
          ⚙ ⮀ ~/build/kafka_2.10-0.8.2.1 ⮀
          » ./bin/kafka-topics.sh --zookeeper localhost:2181 --delete --topic test-topic
          Topic test-topic is marked for deletion.
          Note: This will have no impact if delete.topic.enable is not set to true.
          ⚙ ⮀ ~/build/kafka_2.10-0.8.2.1 ⮀
          » ./bin/kafka-topics.sh --zookeeper localhost:2181 --describe --topic test-topic
          Topic:test-topic PartitionCount:10 ReplicationFactor:1 Configs:
          Topic: test-topic Partition: 0 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 1 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 2 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 3 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 4 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 5 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 6 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 7 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 8 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 9 Leader: -1 Replicas: 0 Isr:

          ⚙ ⮀ ~/build/kafka_2.10-0.8.2.1 ⮀
          » ./bin/kafka-topics.sh --zookeeper localhost:2181 --describe --topic test-topic
          Topic:test-topic PartitionCount:10 ReplicationFactor:1 Configs:
          Topic: test-topic Partition: 0 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 1 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 2 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 3 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 4 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 5 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 6 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 7 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 8 Leader: -1 Replicas: 0 Isr:
          Topic: test-topic Partition: 9 Leader: -1 Replicas: 0 Isr:
          ⚙ ⮀ ~/build/kafka_2.10-0.8.2.1 ⮀
          » ./bin/kafka-topics.sh --zookeeper localhost:2181 --describe --topic test-topic

          Last command doesn't show the topic .

          Hari Sekhon added a comment -

          I've got this same issue with 0.8.2.2 and there are no consumers or producers using the topic that is remaining as marked for deletion but not disappearing from --list or --describe. I even checked I had set the correct variable delete.topic.enable=true and restarted Kafka. This is on HDP 2.3 fully kerberized.

          Ian Kallen added a comment -

          I'm using the ASF release of 0.8.2.2 and I can confirm, topic deletion does not work. The only way to ditch a topic is to stop the brokers, remove the directories on disk, remove the topic from zookeeper and start the brokers back up

          Jun Rao added a comment -

          One thing that you want to make sure is that the delete.topic.enable=true property is indeed set. If you start the broker, we log all overridden properties, could you check if delete.topic.enable is there?

          Vivek Meghanathan added a comment -

          I have 0.8.2.2 version kafka and the delete topic was working fine till today(i am running this version past 1 month). I used to delete the topics at times and it was working fine. Suddenly it stopped working. After multiple restart (and delete from zookeeper client) helped me to remove few topics but 3 of them remains in the server and after a restart of both kafka and zookeeper they are back to active topic. I have ensured all the consumers and producers stopped while removing and restarting the kafka. but still this issue is still there.

          Mayuresh Gharat added a comment -

          Can you paste the server side logs?

          Andrew Duch added a comment -

          I would just like to add that I am still seeing issues deleting topics in 0.9.0. I will delete topics with kafka-topics.sh and it is set as "Marked for Deletion" but never gets deleted. Is this still a known issue?

          On server.log I see lot's of these messages:

          [2016-02-12 21:33:29,480] WARN [Replica Manager on Broker 1]: While recording the replica LEO, the partition [spiderman-pricegrabber-prices,5] hasn't been created. (kafka.server.ReplicaManager)

          On state-change.log, these are samples of the llog entries for this topic after I tried to delete with kafka-topics.sh. For each of these entries, there is typically one per partition... I've just summarized.

          [2016-02-12 21:02:19,585] TRACE Controller 1 epoch 234 changed state of replica 2 for partition [spiderman-pricegrabber-prices,3] from ReplicaDeletionIneligible to OfflineReplica (state.change.logger)
          [2016-02-12 21:02:19,766] TRACE Controller 1 epoch 234 sending UpdateMetadata request (Leader:-2,ISR:1,3,LeaderEpoch:0,ControllerEpoch:234) to broker 1 for partition spiderman-pricegrabber-prices-5 (state.change.logger)
          [2016-02-12 21:02:19,824] ERROR Controller 1 epoch 234 initiated state change of replica 2 for partition [spiderman-pricegrabber-prices,6] from OfflineReplica to ReplicaDeletionIneligible failed (state.change.logger)
          java.lang.AssertionError: assertion failed: Replica [Topic=spiderman-pricegrabber-prices,Partition=6,Replica=2] should be in the ReplicaDeletionStarted states before moving to ReplicaDeletionIneligible state. Instead it is in OfflineReplica state
          [2016-02-12 21:02:20,117] TRACE Controller 1 epoch 234 changed state of replica 1 for partition [spiderman-pricegrabber-prices,4] from OfflineReplica to ReplicaDeletionStarted (state.change.logger)
          [2016-02-12 21:02:20,131] TRACE Broker 1 deleted partition [spiderman-pricegrabber-prices,3] from metadata cache in response to UpdateMetadata request sent by controller 1 epoch 234 with correlation id 1013 (state.change.logger)
          [2016-02-12 21:02:20,132] TRACE Controller 1 epoch 234 received response {error_code=0,partitions=[

          {topic=spiderman-pricegrabber-prices,partition=0,error_code=0}

          ]} for a request sent to broker Node(3, 10.108.0.105, 9092) (state.change.logger)
          [2016-02-12 21:02:20,139] TRACE Broker 1 handling stop replica (delete=false) for partition [spiderman-pricegrabber-prices,5] (state.change.logger)
          [2016-02-12 21:02:20,139] TRACE Broker 1 finished handling stop replica (delete=false) for partition [spiderman-pricegrabber-prices,5] (state.change.logger)
          [2016-02-12 21:02:20,140] TRACE Controller 1 epoch 234 received response {error_code=0,partitions=[

          {topic=spiderman-pricegrabber-prices,partition=7,error_code=0}

          ]} for a request sent to broker Node(3, 10.108.0.105, 9092) (state.change.logger)
          [2016-02-12 21:02:20,151] TRACE Broker 1 handling stop replica (delete=false) for partition [spiderman-pricegrabber-prices,3] (state.change.logger)
          [2016-02-12 21:02:20,151] TRACE Broker 1 finished handling stop replica (delete=false) for partition [spiderman-pricegrabber-prices,3] (state.change.logger)
          [2016-02-12 21:02:20,152] TRACE Controller 1 epoch 234 received response {error_code=0,partitions=[

          {topic=spiderman-pricegrabber-prices,partition=3,error_code=0}

          ]} for a request sent to broker Node(1, 10.108.0.122, 9092) (state.change.logger)
          [2016-02-12 21:02:20,153] TRACE Broker 1 handling stop replica (delete=false) for partition [spiderman-pricegrabber-prices,1] (state.change.logger)
          [2016-02-12 21:02:20,838] TRACE Controller 1 epoch 234 received response {error_code=0,partitions=[

          {topic=spiderman-pricegrabber-prices,partition=4,error_code=0}

          ]} for a request sent to broker Node(1, 10.108.0.122, 9092) (state.change.logger)
          [2016-02-12 21:02:20,838] TRACE Controller 1 epoch 234 changed state of replica 1 for partition [spiderman-pricegrabber-prices,4] from ReplicaDeletionStarted to ReplicaDeletionSuccessful (state.change.logger)
          [2016-02-12 21:02:21,090] TRACE Controller 1 epoch 234 received response {error_code=0,partitions=[

          {topic=spiderman-pricegrabber-prices,partition=6,error_code=0}

          ]} for a request sent to broker Node(3, 10.108.0.105, 9092) (state.change.logger)
          [2016-02-12 21:02:21,090] TRACE Controller 1 epoch 234 changed state of replica 3 for partition [spiderman-pricegrabber-prices,6] from ReplicaDeletionStarted to ReplicaDeletionSuccessful (state.change.logger)

          Ismael Juma added a comment -

          There is also KAFKA-2937 which was fixed for 0.9.0.1.


            People

            • Assignee:
              Timothy Chen
              Reporter:
              Jun Rao
            • Votes:
              2 Vote for this issue
              Watchers:
              19 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development