Kafka
  1. Kafka
  2. KAFKA-139

cross-compile multiple Scala versions and upgrade to SBT 0.12.1

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 0.8.0
    • Component/s: packaging
    • Labels:

      Description

      Since scala does not maintain binary compatibly between versions, organizations tend to have to move all of there code at the same time. It would thus be very helpful if we could cross build multiple scala versions.

      http://code.google.com/p/simple-build-tool/wiki/CrossBuild

      Unclear if this would require KAFKA-134 or just work.

      1. kafka-sbt0-11-3-0.8-v6-smeder.patch
        24 kB
        Sam Meder
      2. kafka-sbt0-11-3-0.8-v5-smeder.patch
        24 kB
        Sam Meder
      3. kafka-sbt0-11-3-0.8-v4.patch
        23 kB
        derek
      4. kafka-sbt0-11-3-0.8-v3.patch
        25 kB
        derek
      5. kafka-sbt0-11-3-0.8-v2.patch
        23 kB
        derek
      6. kafka-sbt0-11-3-0.8.patch
        23 kB
        derek
      7. kafka-sbt0-11-3.patch
        23 kB
        derek

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Chris Burroughs
          • Votes:
            6 Vote for this issue
            Watchers:
            11 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development