Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-13599

Upgrade RocksDB to 6.27.3

    XMLWordPrintableJSON

Details

    • Task
    • Status: Resolved
    • Major
    • Resolution: Resolved
    • None
    • 3.2.0
    • streams
    • None

    Description

      RocksDB v6.27.3 has been released and it is the first release to support s390x. RocksDB is currently the only dependency in gradle/dependencies.gradle without s390x support.

      RocksDB v6.27.3 has added some new options that require an update to streams/src/main/java/org/apache/kafka/streams/state/internals/RocksDBGenericOptionsToDbOptionsColumnFamilyOptionsAdapter.java but no other changes are needed to upgrade.

      A compatibility report is attached for the current version 6.22.1.1 -> 6.27.3

      Attachments

        1. compat_report.html
          159 kB
          Jonathan Albrecht

        Issue Links

          Activity

            People

              jonathan.albrecht Jonathan Albrecht
              jonathan.albrecht Jonathan Albrecht
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: