Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-12850 Use JDK16 for builds instead of JDK15
  3. KAFKA-12790

Remove SslTransportLayerTest.testUnsupportedTlsVersion

Attach filesAttach ScreenshotVotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Sub-task
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 2.4.2, 2.5.2, 2.6.3, 2.7.2, 2.8.1, 3.0.0
    • None
    • None

    Description

      Support for TLS 1.0/1.1 was disabled in recent versions of Java 8/11 and all versions of 16 causing this test to fail. It is possible to make it work by updating the relevant security property, but it has to be done before the affected classes are loaded and it can not be disabled after that. Given the low value of the test, we remove it.

      Attachments

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            ijuma Ismael Juma
            ijuma Ismael Juma
            Rajini Sivaram Rajini Sivaram
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Issue deployment