Kafka
  1. Kafka
  2. KAFKA-1172

error when creating topic with kafka-topics.sh

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Invalid
    • Affects Version/s: 0.8.1
    • Fix Version/s: 0.8.1
    • Component/s: None
    • Labels:
      None

      Description

      when trying to-do this
      bin/kafka-topics.sh --create --zookeeper 192.168.50.5:2181 --replication-factor 3 --partitions 3 --topic testing

      I am getting this

      Exception in thread "main" java.lang.NoSuchMethodError: kafka.admin.AdminUtils$.createTopic(Lorg/I0Itec/zkclient/ZkClient;Ljava/lang/String;IILjava/util/Properties;)V
      at kafka.admin.TopicCommand$$anonfun$createTopic$1.apply(TopicCommand.scala:73)
      at kafka.admin.TopicCommand$$anonfun$createTopic$1.apply(TopicCommand.scala:65)
      at scala.collection.Iterator$class.foreach(Iterator.scala:631)
      at scala.collection.JavaConversions$JIteratorWrapper.foreach(JavaConversions.scala:474)
      at scala.collection.IterableLike$class.foreach(IterableLike.scala:79)
      at scala.collection.JavaConversions$JListWrapper.foreach(JavaConversions.scala:521)
      at kafka.admin.TopicCommand$.createTopic(TopicCommand.scala:65)
      at kafka.admin.TopicCommand$.main(TopicCommand.scala:48)
      at kafka.admin.TopicCommand.main(TopicCommand.scala)

      however listing works fine

      vagrant@precise64:/opt/kafka$ bin/kafka-topics.sh --list --zookeeper 192.168.50.5:2181
      sandbox

        Activity

        Jun Rao added a comment -

        The following works for me.

        bin/kafka-topics.sh --create --zookeeper localhost:2181 --replication-factor 1 --partitions 1 --topic testing

        Can you reproduce this locally?

        Joe Stein added a comment -

        weird, I did an sbt clean and rebuilt everything and it worked fine... should have tried that first. thanks


          People

          • Assignee:
            Unassigned
            Reporter:
            Joe Stein
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development