Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-9755 Implement versioning scheme for features
  3. KAFKA-10623

[Easy] Refactor code to avoid discovery conflicts for classes:{Supported|Finalized}VersionRange

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      This Jira suggests changing few existing class names to avoid class discovery conflicts. Particularly the following classes:

      org.apache.kafka.clients.admin.{Supported|Finalized}VersionRange

      conflict with

       

       

      org.apache.kafka.common.feature.{Supported|Finalized}VersionRange

      The former is internal facing, while the latter is external facing (since it is used in the Admin#describeFeatures API). So, the internal facing classes can be renamed suitably. Possible alternative naming suggestions:

       

       

      org.apache.kafka.clients.admin.{Supported|Finalized}Versions
      
      org.apache.kafka.clients.admin.Broker{Supported|Finalized}Versions
      
      org.apache.kafka.clients.admin.Broker{Supported|Finalized}VersionRange

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                kprakasam Kowshik Prakasam
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: