jUDDI
  1. jUDDI
  2. JUDDI-785

find with CASE_INSENSITIVE_SORT throws JPA exception

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.2
    • Component/s: core
    • Labels:
      None

      Description

      JUDDI_764caseInsensitiveSortTModelKey(org.apache.juddi.v3.tck.UDDI_070_FindEntityIntegrationTest) Time elapsed: 0.066 sec <<< ERROR!
      javax.xml.ws.soap.SOAPFaultException: "Encountered "upper" at character 670, but expected: ["AVG", "COUNT", "KEY", "MAX", "MIN", "SUM", "VALUE", <IDENTIFIER>]." while parsing JPQL "select t from Tmodel t where 1=1 and t.entityKey in ( ?1, ?2, ?3, ?4, ?5, ?6, ?7, ?8, ?9, ?10, ?11, ?12, ?13, ?14, ?15, ?16, ?17, ?18, ?19, ?20, ?21, ?22, ?23, ?24, ?25, ?26, ?27, ?28, ?29, ?30, ?31, ?32, ?33, ?34, ?35, ?36, ?37, ?38, ?39, ?40, ?41, ?42, ?43, ?44, ?45, ?46, ?47, ?48, ?49, ?50, ?51, ?52, ?53, ?54, ?55, ?56, ?57, ?58, ?59, ?60, ?61, ?62, ?63, ?64, ?65, ?66, ?67, ?68, ?69, ?70, ?71, ?72, ?73, ?74, ?75, ?76, ?77, ?78, ?79, ?80, ?81, ?82, ?83, ?84, ?85, ?86, ?87, ?88, ?89, ?90, ?91, ?92, ?93, ?94, ?95, ?96, ?97, ?98, ?99, ?100, ?101, ?102, ?103, ?104, ?105, ?106, ?107, ?108, ?109, ?110, ?111, ?112, ?113, ?114, ?115, ?116, ?117, ?118, ?119) order by upper(t.name) asc, t.modified desc". See nested stack trace for original parse error.

      FindTModel fb = new FindTModel();
      fb.setAuthInfo(authInfoJoe);
      fb.setFindQualifiers(new FindQualifiers());
      fb.getFindQualifiers().getFindQualifier().add(UDDIConstants.CASE_INSENSITIVE_SORT_TMODEL);
      fb.getFindQualifiers().getFindQualifier().add(UDDIConstants.APPROXIMATE_MATCH);
      fb.setName(new Name(UDDIConstants.WILDCARD, null));
      inquiry.findTModel(fb);

        Issue Links

          Activity

          Alex O'Ree added a comment -

          This also applies to business and services

          Alex O'Ree added a comment -

          I've been through all of the find qualifiers, only case insensitive sort is broken. all of the other at least don't crash

          Kurt T Stam added a comment -

          Hi Alex, how to reproduce?

          Alex O'Ree added a comment -

          UDDI_070_FindEntityIntegrationTest see @Ignore tests

          Kurt T Stam added a comment -

          Right; looks like an issue with the JPA specification which does not support UPPER:

          https://issues.apache.org/jira/browse/OPENJPA-1817

          Kurt T Stam added a comment -

          jUDDI now ignores caseInsensitive sorting, a workaround is to do a caseInsensitive match. The javadoc has been updated accordingly.

          Kurt T Stam added a comment -

          jUDDI won't support case insensitive sort, unless the JPA spec is updated to support it. The workaround is to perform an case insensitive match.

          Alex O'Ree added a comment -

          need to remove the code for the fq that we don't support, then enable the tck tests

          ASF subversion and git services added a comment -

          Commit 1560361 from Kurt T Stam in branch 'juddi/trunk'
          [ https://svn.apache.org/r1560361 ]

          JUDDI-785 ignore caseInsensitiveSort

          Kurt T Stam added a comment -

          Y agreed.. might help if I had checked in the code . It is now.

          Alex O'Ree added a comment -

          Each of the pre-defined findQualifiers in UDDI can be referenced using either the appropriate tModelKey, or by its short name. Registries MUST support both forms, and MUST accept the find qualifiers case-insensitively. The use of tModelKeys for findQualifiers allows extension to create additional new qualifiers, but registries are not obligated to support them.

          ==> Find qualifiers not recognized by a node will return the error E_unsupported.

          I'm pretty sure we don't do this.

          ASF subversion and git services added a comment -

          Commit 1563432 from Alex O'Ree in branch 'juddi/trunk'
          [ https://svn.apache.org/r1563432 ]

          JUDDI-785 enabling all CASE_INSENSITIVE_SORT tests with exclusions for juddi, adding tests for unknown find qualifiers and validators to throw on unsupported fqs

          Alex O'Ree added a comment -

          Now we throw on unsupported find qualifiers and invalid combinations

          ASF subversion and git services added a comment -

          Commit 1563451 from Alex O'Ree in branch 'juddi/trunk'
          [ https://svn.apache.org/r1563451 ]

          JUDDI-785 fixing javadoc references


            People

            • Assignee:
              Alex O'Ree
              Reporter:
              Alex O'Ree
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development