Uploaded image for project: 'JSPWiki'
  1. JSPWiki
  2. JSPWIKI-817

Install.jsp is broken, and should be more foolproof and provide better guidance

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.10
    • Fix Version/s: 2.10.1
    • Component/s: Core & storage
    • Labels:
      None
    • Environment:

      Ubuntu Linux
      Java 7
      Tomcat 7
      JSPWiki 2.10.0

      Description

      Firing up the JSPWiki/Install.jsp gives the following NPE:

      Feb 02, 2014 1:59:04 PM org.apache.catalina.core.StandardWrapperValve invoke
      SEVERE: Servlet.service() for servlet [jsp] in context with path [/wiki] threw exception [An exception occurred processing JSP page /Install.jsp at line 46
      
      43: WikiSession wikiSession = wikiContext.getWikiSession();
      44: 
      45: // Parse the existing properties
      46: installer.parseProperties();
      47: boolean validated = false;
      48: String password = null;
      49: ResourceBundle rb = Preferences.getBundle( wikiContext, "CoreResources" );
      
      
      Stacktrace:] with root cause
      java.lang.NullPointerException
      	at org.apache.wiki.util.CommentedProperties.writeProperty(CommentedProperties.java:213)
      	at org.apache.wiki.util.CommentedProperties.put(CommentedProperties.java:116)
      	at org.apache.wiki.ui.Installer.parseProperty(Installer.java:320)
      	at org.apache.wiki.ui.Installer.parseProperties(Installer.java:223)
      	at org.apache.jsp.Install_jsp._jspService(Install_jsp.java:122)
      	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
      	at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:432)
      	at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
      	at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
      	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)
      	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      	at org.apache.wiki.ui.WikiServletFilter.doFilter(WikiServletFilter.java:177)
      	at org.apache.wiki.ui.WikiJSPFilter.doFilter(WikiJSPFilter.java:121)
      	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
      	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
      	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
      	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
      	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
      	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:947)
      	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
      	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:408)
      	at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1009)
      	at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
      	at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:310)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:724)
      
      

      This issue was introduced in 2.10.0-svn-36 (introduction of jspwiki-custom.properties file)

      This was not reflected in Install.jsp.
      The jspwiki.properties file was moved into WEB-INF/lib/jspwiki-war-<version>.jar .

      We should update the Installer:

      • to read from this default jspwiki.properties file
      • change the instructions
      • save the new properties to something like /tmp/jspwiki-custom.properties
      • instruct to copy this file to a location that is classpath-readable

        Issue Links

          Activity

          juanpablo Juan Pablo Santos Rodríguez added a comment -

          closing resolved issues for 2.10.1

          metskem Harry Metske added a comment -

          Not that I'm aware of.

          regards,
          Harry

          mingshihua Shihua added a comment -

          Hi, Harry

          Thank you for your quick reply.
          I built the release file from the source code successfully.
          Now I am looking at the source code.
          Can I ask you is there any document about source code or JSPWiki Hierarchy?

          Thank you.

          Shihua.

          metskem Harry Metske added a comment -

          nowhere yet, we are working on the release of it. Once release you will
          find it on the download page.

          regards,
          Harry

          mingshihua Shihua added a comment -

          Hi I am new for JSPWiki and try to install it. I have the same above problem, so I want to ask where can I find version 2.10.1?

          Thank you.

          cpendleton Curtis Pendleton added a comment -

          I am no longer working for Active Network. For Active Network business, please contact Jerry Wilbers (jerry.wilbers@activenetwork.com) in my absence. For personal, please contact me at curtis.pendleton@gmail.com.

          fendorn Markus Ebel added a comment -

          I also lost approx. two hours before I came here. A note would be really nice ! and of course a new build with the correction. I would use a minor version (2.9), but this is not available (anymore?). Annoying ...

          metskem Harry Metske added a comment -

          Jürgen, if I remember correctly I changed quite a few values and keys in the resource files, but only in NL en EN. And JP later changed the ES files.
          All other languages need to be updated.
          See http://svn.apache.org/viewvc/jspwiki/trunk/jspwiki-war/src/main/resources/CoreResources.properties?r1=1505241&r2=1566003&pathrev=1566003 .

          kind regards,
          Harry

          weberjn Jürgen Weber added a comment -

          Harry,

          CoreResources_de.properties / install.* look good to me, what are you missing?

          juanpablo Juan Pablo Santos Rodríguez added a comment -

          Hi!

          es_ES translation was also updated at r1569989. As for the release, it seems it'll be very welcome, let's follow this up at dev@j.a.o

          br,
          juan pablo

          metskem Harry Metske added a comment -

          Well, the issue has been fixed (except that we don't have the modified translations yet for all languages, only EN and NL). So, German Ubersetzung would be nice to have too. See rev. 1566003.

          What we need is a new release, I hope Juan Pablo Santos Rodríguez has some time to think about that.

          regards,
          Harry

          ngong Rolf Schumacher added a comment -

          I too lost a few hours on this issue until I came up here. Really annoying. I would recommend to fix it asap, too.

          bertkoor Bert Koorengevel added a comment - - edited

          I ran into this issue today while attempting to install a new JspWiki, extremely annoying!
          Tried to fetch v2.10.1 through some url hacking http://www.apache.org/dyn/closer.cgi/jspwiki/2.10.1/ but that doesn't exist. The downloads page http://jspwiki.apache.org/general/downloads.html points to Apache archives at http://archive.apache.org/dist/jspwiki/ but that contains only the broken 2.10.0 version. No traces of a v2.9.x <
          I could do the Advanced Installation, but it really should run straight out of the box. Please get your act together ASAP!

          weberjn Jürgen Weber added a comment -

          The fix should be released asap, right now everybody who tries the Apache project JSPWiki will get a failure. This is not good.
          At least https://jspwiki-wiki.apache.org/Wiki.jsp?page=Getting%20Started
          should be changed, so that people will do the Advanced Installation.
          Also, the jspwiki.properties from https://jspwiki-wiki.apache.org/Wiki.jsp?page=Documentation#section-Documentation-SectionDocumentationConfigurationAndAdministration should go into an attachment called jspwiki-custom.properties and be linked from Getting%20Started, because there is no jspwiki.properties in the war.

          metskem Harry Metske added a comment -

          Fixed in 2.10.0-svn-70.

          Translations should be updated though !

          metskem Harry Metske added a comment - - edited

          And that messing up only occurs for the bottom part of the Install.jsp where we call

          <%=installer.getProperties()%>
          
          metskem Harry Metske added a comment -

          I had an hour, so I got a draft Installer working, but it looks like CommentedProperties is messing up the parameters because those parameters are already (commented out) in the ini/jspwiki.properties.
          I also made quite a few changes to the CoreResources.properties to get some more clear explanation.
          I hope to get some time this week, but anyone feel free to step in here.


            People

            • Assignee:
              metskem Harry Metske
              Reporter:
              metskem Harry Metske
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development