We haven't had any activity on this issue for a while, so I would like to recap my latest proposal for this issue.
Per a friendly beer discussion I had with Janne last year (plus a few follow-up e-mails), I propose we do the following:
- The official API package, for stable interfaces (primarily) and stable classes (where possible) is "org.apache.wiki".
- The implementation package is "org.apache.wikibase" or "org.apache.wikicore". This package name is still fairly short and snappy, but isn't as ugly as tacking on an "-impl" suffix to "wiki" might be.
- Separate Eclipse source folders for the two package trees.
- Separate JAR files for the wiki.* and wikbase.* classes.
Can I request a vote on this? Please post your comments in JIRA.