Jetspeed 2
  1. Jetspeed 2
  2. JS2-984

Jetspeed 2.2 Validation on Websphere 6.1

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Websphere/WAS 6.1/Linux

      Description

      Jetspeed 2.2 reportedly has issues running in the Websphere/WAS. At a minimum, login via the PortletFilter is apparently failing.

      Need to fix and validate basic portal functionality in Websphere/WAS environment.

        Issue Links

          Activity

          Randy Watler added a comment -

          Issue caused by session invalidation interference between LoginProxyServlet and PortalFilter implementation of createNewSessionOnLogin authentication configuration.

          Commit: 771393

          Ate Douma added a comment -

          One part of authentication problems was caused by too aggressive request unwrapping by the DefaultContainerRequestResponseUnwrapper before invoking a portlet.
          This caused the authentication state (UserPrincipal) as setup by the PortalFilter with the PortalRequestWrapper to get "lost".
          I've just committed a solution for that using a new marker interface ContainerRequiredRequestResponseWrapper, and applied that on the PortalRequestWrapper as well the PortalRequest (special wrapper for Websphere).

          However, even with that, by default login is still now working on Websphere.

          This turns out to be caused by PortalAdministrationConfiguration.isCreateNewSessionOnLogin() now by default being configured to true.
          Somehow the session.invalidate() before the authentication and getSession(true) right thereafter is somehow "losing" the authentication state on Websphere.
          After I changed this configuration setting to false in assembly/administration.xml, I could login successfully again.


            People

            • Assignee:
              Randy Watler
              Reporter:
              Randy Watler
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development