Jetspeed 2
  1. Jetspeed 2
  2. JS2-930

Expires header set to 0 does not cause round-trip in IE

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 2.2.1
    • Component/s: Components Core
    • Labels:
      None

      Description

      As reported by Remco Nabuurs. Jetspeed sets the following HTTP response headers by default:

      Cache-Control: no-store, no-cache, private
      Pragma: no-cache
      Expires: 0

      To force a round trip in IE when pressing the BACK button, the expires header needs to be set to -1. Firefox and Safari assign a higher priority to the expires header and perform a round trip. When an application makes use of Ajax calls in-between requests, and an application architecture is adhered (the Ajax calls change server state), this leads to pages with out-of-sync data.

        Activity

        Dennis Dam added a comment -

        I wasn't able to reproduce this bug in IE 5.5 / 6 / 7 using Jetspeed 2.2-SNAPSHOT

        What I did:

        Installed jetspeed trunk in a local tomcat.
        Go to http://localhost:8080/jetspeed/portal
        Go to a random page
        Press back button
        In Fiddler I see the round-trip happening for IE 5.5 / 6 / 7. Btw, also tested it in Chrome: works fine as well.

        Also tested it with the Jetspeed desktop (Ajaxized version of the portal, http://localhost:8080/desktop), navigating back and forth using the back/forward button does not show outdated content. Using Fiddler, I see the caching headers mentioned above. Remco, could you provide more details on this issue?

        Dennis Dam added a comment -

        sent a reminder to Remco, waiting for response.

        Dennis Dam added a comment -

        they're using a workaround in html now by setting the meta-equiv "Cache-Control" to "max-age=-1".

        Dennis Dam added a comment -

        postponing it until the next release.

        More info: http://support.microsoft.com/kb/234067

        Ate Douma added a comment -

        Dennis, I think you more than enough tested the reported issue without being able to reproduce.
        If someone still encounters this problem, please create a new issue instead.
        Closing as "Cannot Reproduce"


          People

          • Assignee:
            Dennis Dam
            Reporter:
            Dennis Dam
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development