Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.1.2
    • Fix Version/s: 2.2.2
    • Labels:
      None

      Description

      There are two data structures in the profiler, both are synchronized hash maps. The combined size of the two data
      structures grows linearly with the number of users. These data structures will be refactored to increase memory conservation.
      A lot of the data in these maps is redundant. I am going to reduce the footprint by storing only minimally required data.
      Additionally, we will use ehcache to control the size of these data structures.

        Issue Links

          Activity

          David Sean Taylor added a comment -

          This is issue is a duplicate of https://issues.apache.org/jira/browse/JS2-676
          We will address it in 2.2

          David Sean Taylor added a comment -

          moving to 2.2.1. We found areas we want to improve on while working 676

          David Sean Taylor added a comment -

          duplicate of 676


            People

            • Assignee:
              David Sean Taylor
              Reporter:
              David Sean Taylor
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 8h
                8h
                Remaining:
                Remaining Estimate - 8h
                8h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development