Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.2
    • Fix Version/s: 2.2.0
    • Labels:
      None
    • Environment:
      Jetspeed-2.1.2/Solaris10/Java-1.5.0._10

      Description

      When the user is redirected from the LoginPortlet to a custom ChangePasswordPortlet due to an expired password, the actionURL points to the original page rather than the currently rendered page. This prevents the processAction from being executed and does not allow the user's password change to be executed.

      Steps to reproduce:
      1- Create a new user with an expiration in the near future.
      2- Validate that the user can log in prior to the expiration. Log out and wait until password has expired.
      3- Login to new account. User is redirected to the Update My Account page displaying the Change Password portlet.
      4- View source to examine actionURL.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        504d 7h 19m 1 Ate Douma 07/Apr/09 02:07
        Resolved Resolved Closed Closed
        910d 19h 59m 1 Ate Douma 04/Oct/11 22:07
        Ate Douma made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Ate Douma made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.2.0 [ 12312318 ]
        Resolution Fixed [ 1 ]
        Ate Douma added a comment -

        Just tested again with the latest 2.2.0 trunk and cannot reproduce anymore so resolving as now fixed.

        Ate Douma made changes -
        Field Original Value New Value
        Assignee Ate Douma [ adouma ]
        Jennifer Ford created issue -

          People

          • Assignee:
            Ate Douma
            Reporter:
            Jennifer Ford
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development