Jetspeed 2
  1. Jetspeed 2
  2. JS2-681

Login portlet doesn't run in Tomcat ROOT context

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.1.2
    • Component/s: Admin Portlets
    • Labels:
      None
    • Environment:
      JDK 1.6, Tomcat 5.5, Linux Ubuntu 6.10

      Description

      We have changed the application context of a Jetspeed 2 portal from "/$

      {artifactId}

      " to "/". Doing that, the Jetspeed portal runs perfectly but the Login portlet fails. The portal throws the following exception:

      javax.portlet.PortletException
      at org.apache.jetspeed.dispatcher.JetspeedRequestDispatcher.include(JetspeedRequestDispatcher.java:102)
      at org.apache.portals.bridges.common.GenericServletPortlet.doView(GenericServletPortlet.java:363)
      at javax.portlet.GenericPortlet.doDispatch(GenericPortlet.java:247)
      ......
      Caused by: javax.servlet.ServletException: In URL tags, when the "context" attribute is specified, values of both "context" and "url" must start with "/".

      The problem is that the "context" attribute of the "<c:url />" tag cannot have an empty value. The empty value is returned by the "$

      {requestContext.request.contextPath}

      " expression (see the Servlet API::HttpServletRequest.getContextPath() to know the reason).

      We have attached a patch that fix this bug. In addition to this patch, the JSTL API and implementation must be upgraded to jstl-1.1.1.jar and standard-1.1.2.jar.

      Regards.

      1. patch-login-portlet.txt
        6 kB
        Enrique Ruiz (DiSiD Technologies S.L.)

        Activity

        Enrique Ruiz (DiSiD Technologies S.L.) created issue -
        Enrique Ruiz (DiSiD Technologies S.L.) made changes -
        Field Original Value New Value
        Attachment patch-login-portlet.txt [ 12355684 ]
        Ate Douma made changes -
        Assignee Ate Douma [ adouma ]
        Ate Douma made changes -
        Fix Version/s 2.1.1 [ 12312462 ]
        Ate Douma added a comment -

        Patch applied and upgrade jstl and standard libs to version 1.1.2
        Jetspeed working nicely now deployed under ROOT

        Ate Douma made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Ate Douma added a comment -

        While testing with Jetty, it turns out these fixes create invalid urls like /jetspeed//login/proxy (notice the double slashes).

        Ate Douma made changes -
        Status Resolved [ 5 ] Reopened [ 4 ]
        Resolution Fixed [ 1 ]
        Ate Douma added a comment -

        Should be properly fixed now

        Ate Douma made changes -
        Resolution Fixed [ 1 ]
        Status Reopened [ 4 ] Resolved [ 5 ]
        Ate Douma made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        22d 20h 19m 1 Ate Douma 10/May/07 09:00
        Resolved Resolved Reopened Reopened
        39d 5h 47m 1 Ate Douma 18/Jun/07 14:47
        Reopened Reopened Resolved Resolved
        8m 29s 1 Ate Douma 18/Jun/07 14:56
        Resolved Resolved Closed Closed
        1569d 7h 41m 1 Ate Douma 04/Oct/11 22:37

          People

          • Assignee:
            Ate Douma
            Reporter:
            Enrique Ruiz (DiSiD Technologies S.L.)
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development