Jetspeed 2
  1. Jetspeed 2
  2. JS2-590

Moving / Deleting portlets doesn't always work under DatabasePageManager

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.1-dev
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Java 1.5, Oracle, DatabasePageManager

      Description

      Moving and deleting portlets doesn't always work. Usually works if it's the first thing done after "editing" the page, but then is unpredictable after that.

        Activity

        David Sean Taylor added a comment -

        We worked on this for the better part of day (with Mohan K) and we could not reproduce it

        David Sean Taylor added a comment -

        Working on a patch to layouts that may be the root cause

        Ate Douma added a comment -

        Closed again now properly recorded against Fix Version 2.1 as well

        David Sean Taylor added a comment -

        Patch applied, passes tests, preliminary testing by reporter passed.
        Please reopen if further testing fails

        Ethan Adams added a comment -

        I've installed the updates into my staging environment. Looks at first glance.

        I am in the middle of UAT, so it should be well tested over the next couple weeks. I also plan to run some load tests.

        I'll report back any issues.

        David Sean Taylor added a comment -

        I applied a fix that works here for me to the SVN head. Ethan, could you please test this and let me know how it works for you? Thanks

        David Sean Taylor added a comment -

        I have a fix for this. Hope to get it committed tonight.

        Joachim Müller added a comment -

        Have you had a look at this issue: JS2-571 ?

        Yang Sie added a comment -

        what I had experienced was that under load condition (~10 users used the application at the same time, sort of to load test the app manually). people were unable to delete or move portlets. All portlets that had been deleted or moved were still showing on the page where they were. However, the database did seem to get updated because after the current session (the browser) was closed and a new browser was reopened, all those deleted portlets disappeared. The test was done under the database pageManager.

        Ethan Adams added a comment -

        Standard portal page customizer.

        I should add that when I delete a portlet (and I think move) it does update the database. I've even called the PageManager.reset() while testing the problem, but it didn't help.

        David Sean Taylor added a comment -

        are you using the ajax api or the /portal page customizer?


          People

          • Assignee:
            David Sean Taylor
            Reporter:
            Ethan Adams
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development