Jetspeed 2
  1. Jetspeed 2
  2. JS2-588

"Portal Site Detail" portlet doesn't work in trunk

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1-dev
    • Fix Version/s: 2.1-dev, 2.1
    • Component/s: Admin Portlets
    • Labels:
      None
    • Environment:
      apache-tomcat-5.5.17

      Description

      Portal Site Detail portlet doesn't work in trunk.
      On first open page "Portal Site Manager" there is an error within "Portal Site Detail" portlet:

      Failed to load portlet org.apache.jetspeed.portlets.site.SiteDetailsPortlet: java.lang.NoSuchMethodError: org.springframework.beans.factory.xml.XmlBeanFactory.(Ljava/io/InputStream;)V

      On next open this page there is another error within "Portal Site Detail" portlet:

      Portlet is Not Available: j2-admin::PortalSiteDetail
      Reason: null

      In log there is next stack trace:

      java.lang.NullPointerException
      at org.apache.portals.bridges.frameworks.spring.PortletApplicationModelImpl.getTemplate(PortletApplicationModelImpl.java:258)
      at org.apache.portals.bridges.frameworks.GenericFrameworkPortlet.doRender(GenericFrameworkPortlet.java:474)
      at org.apache.portals.bridges.frameworks.GenericFrameworkPortlet.doView(GenericFrameworkPortlet.java:456)
      at org.apache.jetspeed.portlets.site.SiteDetailsPortlet.doView(SiteDetailsPortlet.java:123)
      at javax.portlet.GenericPortlet.doDispatch(GenericPortlet.java:247)
      at javax.portlet.GenericPortlet.render(GenericPortlet.java:175)
      at org.apache.portals.bridges.velocity.GenericVelocityPortlet.render(GenericVelocityPortlet.java:163)
      at org.apache.jetspeed.factory.JetspeedPortletInstance.render(JetspeedPortletInstance.java:102)
      at org.apache.jetspeed.container.JetspeedContainerServlet.doGet(JetspeedContainerServlet.java:235)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
      at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:672)
      at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:574)
      at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:499)
      at org.apache.jetspeed.container.invoker.ServletPortletInvoker.invoke(ServletPortletInvoker.java:215)
      at org.apache.jetspeed.container.invoker.ServletPortletInvoker.render(ServletPortletInvoker.java:126)
      at org.apache.pluto.PortletContainerImpl.renderPortlet(PortletContainerImpl.java:119)
      at org.apache.jetspeed.container.JetspeedPortletContainerWrapper.renderPortlet(JetspeedPortletContainerWrapper.java:120)
      at org.apache.jetspeed.aggregator.impl.RenderingJobImpl.execute(RenderingJobImpl.java:121)
      at org.apache.jetspeed.aggregator.impl.PortletRendererImpl.renderNow(PortletRendererImpl.java:120)
      at org.apache.jetspeed.aggregator.impl.PageAggregatorImpl.aggregateAndRender(PageAggregatorImpl.java:199)
      at org.apache.jetspeed.aggregator.impl.PageAggregatorImpl.aggregateAndRender(PageAggregatorImpl.java:182)
      at org.apache.jetspeed.aggregator.impl.PageAggregatorImpl.build(PageAggregatorImpl.java:106)
      at org.apache.jetspeed.aggregator.AggregatorValve.invoke(AggregatorValve.java:48)
      at org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:166)
      at org.apache.jetspeed.decoration.DecorationValve.invoke(DecorationValve.java:110)
      at org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:166)
      at org.apache.jetspeed.pipeline.valve.impl.ActionValveImpl.invoke(ActionValveImpl.java:151)
      at org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:166)
      at org.apache.jetspeed.container.ContainerValve.invoke(ContainerValve.java:76)
      at org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:166)
      at org.apache.jetspeed.profiler.impl.ProfilerValveImpl.invoke(ProfilerValveImpl.java:255)
      at org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:166)
      at org.apache.jetspeed.security.impl.LoginValidationValveImpl.invoke(LoginValidationValveImpl.java:159)
      at org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:166)
      at org.apache.jetspeed.security.impl.PasswordCredentialValveImpl.invoke(PasswordCredentialValveImpl.java:149)
      at org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:166)
      at org.apache.jetspeed.localization.impl.LocalizationValveImpl.invoke(LocalizationValveImpl.java:169)
      at org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:166)
      at org.apache.jetspeed.security.impl.AbstractSecurityValve$1.run(AbstractSecurityValve.java:117)
      at java.security.AccessController.doPrivileged(Native Method)
      at javax.security.auth.Subject.doAsPrivileged(Subject.java:454)
      at org.apache.jetspeed.security.impl.AbstractSecurityValve.invoke(AbstractSecurityValve.java:111)
      at org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:166)
      at org.apache.jetspeed.container.url.impl.PortalURLValveImpl.invoke(PortalURLValveImpl.java:67)
      at org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:166)
      at org.apache.jetspeed.capabilities.impl.CapabilityValveImpl.invoke(CapabilityValveImpl.java:128)
      at org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:166)
      at org.apache.jetspeed.pipeline.JetspeedPipeline.invoke(JetspeedPipeline.java:145)
      at org.apache.jetspeed.engine.JetspeedEngine.service(JetspeedEngine.java:214)
      at org.apache.jetspeed.engine.JetspeedServlet.doGet(JetspeedServlet.java:241)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:432)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
      at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
      at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
      at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
      at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
      at java.lang.Thread.run(Thread.java:595)

        Issue Links

          Activity

          David Sean Taylor added a comment -

          Its being deprecated. Will replace it with a new site portlet work-in-progress

          Ate Douma added a comment -

          I know these portlets will be replaced soon, but I need a fix now for a demo tomorrow.

          I looked into it and it turns out this is caused by an springframework 2.0 interface change on XmlBeanFactory.
          They dropped the constructor with an InputStream parameter
          This means the current bridges-frameworks-1.0 can't be used with Springframework 2.0 anymore.

          I already modified and tested a fix for this and I've got it working again.
          So, I will create a Portals Bridges JIRA issue for this, update the bridges-frameworks to version 1.0.1-dev and commit my fix.
          Then I'll adjust the j2-admin application to use this new version.

          Ate Douma added a comment -

          Fixed by updating to the new frameworks bridge 1.0.1-dev.

          NOTE: this new framework bridge isn't available from an online maven repository yet, so you will have to build and install the frameworks bridge yourself first !

          David: could you maybe update bridges and deploy the latest 1.0.1-dev jars to your bluesunrise maven repo?


            People

            • Assignee:
              Ate Douma
              Reporter:
              Vitaly Baranovsky
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development