Jetspeed 2
  1. Jetspeed 2
  2. JS2-556

decorator.vm in portlet decorators not overriden

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-dev/cvs, 2.1-dev, 2.1
    • Fix Version/s: 2.1-dev, 2.1
    • Component/s: Layout
    • Labels:
      None
    • Environment:
      any

      Description

      I cannot override the default decorator.vm in my portlet decorator. Although the file is created in my decorator's home, the default one is still used for rendering portlets.

        Activity

        Jacek Wi?licki created issue -
        David Sean Taylor made changes -
        Field Original Value New Value
        Assignee David Sean Taylor [ taylor ]
        David Sean Taylor made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        David Sean Taylor added a comment -

        Try naming your resource header.vm, not decorator.vm
        That should work

        Jacek Wi?licki added a comment -

        In case of a plotle (not layout)t decorator? It doesn't work, anyway The comment in the default decorator.vm states:

        This is the default template to be used for rendering decorations. If you
        find you cannot accomplish your design requirements by defining a custom
        style sheet for your decoration, you can define your own decorator.vm in
        the root of your decortaion. This will be used instead of the default.

        Jacek Wi?licki added a comment -

        It should be: "In case of a portlet (not layout) decorator"...

        David Sean Taylor added a comment -

        With layout decorators, use header.vm
        With portlet decorators, use decorator.vm

        I tested this again tonight, still can't reproduce the bug
        Im sorry but it WFM on svn trunk

        David Sean Taylor made changes -
        Status In Progress [ 3 ] Open [ 1 ]
        David Sean Taylor added a comment -

        Closing as this appears to be resolved.

        David Sean Taylor made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 2.1-dev [ 12310686 ]
        Ate Douma made changes -
        Status Closed [ 6 ] Reopened [ 4 ]
        Resolution Fixed [ 1 ]
        Ate Douma added a comment -

        Closed again now properly recorded against Fix Version 2.1 as well

        Ate Douma made changes -
        Resolution Fixed [ 1 ]
        Fix Version/s 2.1 [ 12310617 ]
        Status Reopened [ 4 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        6d 22h 13m 1 David Sean Taylor 24/Jul/06 18:20
        In Progress In Progress Open Open
        216d 15h 40m 1 David Sean Taylor 26/Feb/07 09:01
        Open Open Closed Closed
        31s 1 David Sean Taylor 26/Feb/07 09:01
        Closed Closed Reopened Reopened
        4d 13h 30m 1 Ate Douma 02/Mar/07 22:31
        Reopened Reopened Closed Closed
        10s 1 Ate Douma 02/Mar/07 22:32

          People

          • Assignee:
            David Sean Taylor
            Reporter:
            Jacek Wi?licki
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development