Jetspeed 2
  1. Jetspeed 2
  2. JS2-511

org.apache.jetspeed.om.portlet.impl.PortletDefinitionImpl line 558 throws NPE

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.1-dev
    • Fix Version/s: 2.1-dev, 2.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      WinXP SP2, JDK 1.4.2_11, Geronimo SVN head, Tomcat 5.5.15

      Description

      Geronimo default log level is debug. When an porltet app try to register itself to j2, commons-beanutils will call PortletDefinitionImpl.hashCode() to write a log. The issue is caused by PortletDefinitionImpl.getId() will return a null in PortletDefinitionImpl.hashCode(), line 558.

      Reproduce:
      1. Change your log level to debug(jetspeed\WEB-INF\conf\Log4j.properties).
      2. Have a full build and call j2:quickStart
      3. Start your Tomcat Server if you do not has a Geronimo.

      I've tested it with Tomcat 5.5.15 and Geronimo SVN head.

        Activity

        Ate Douma added a comment -

        Confirmed and fixed.

        Now all portlet apps are properly loaded/registered even with rootLevel logging set to DEBUG.


          People

          • Assignee:
            Ate Douma
            Reporter:
            Jian Liao
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development