Jetspeed 2
  1. Jetspeed 2
  2. JS2-282

Error when session expires and portlet window is maximized

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.2
    • Fix Version/s: 2.1.2
    • Component/s: Container
    • Labels:
      None
    • Environment:
      Tomcat 5.5.23, Windows XP, Oracle

      Description

      Maximizing a portlet after the session expired causes an exception. The login screen should be onened.

      This can be reproduced when leaving a portal page open in the browser. Then when the session is expired click on the maximize icon of a portlet.

      I attached the error output html as a file.

      1. error.html
        4 kB
        Martin Dulisch
      2. jetspeed_error.htm
        15 kB
        Martin Dulisch

        Activity

        Martin Dulisch created issue -
        Martin Dulisch added a comment -

        Error output

        Martin Dulisch made changes -
        Field Original Value New Value
        Attachment error.html [ 12310689 ]
        Michael Lipp made changes -
        Fix Version/s 2.0-POST [ 12310617 ]
        Ate Douma added a comment -

        I tried it out with current trunk 2.1-dev and I can't reproduce this (anymore).
        Probably already fixed long time ago

        Ate Douma made changes -
        Resolution Cannot Reproduce [ 5 ]
        Status Open [ 1 ] Closed [ 6 ]
        Martin Dulisch added a comment -

        This bug is still there in 2.1.1-dev (trunk).

        It appears when an action link is selected in an maximized portlet and the session (portal login) expired.

        If the portlet windows is not maximized, selecting the action link opens the login page.

        I appended the error trace as html.

        Martin Dulisch made changes -
        Resolution Cannot Reproduce [ 5 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Martin Dulisch made changes -
        Fix Version/s 2.1 [ 12310617 ]
        Affects Version/s 2.1.1 [ 12312462 ]
        Affects Version/s 2.0-M3 [ 11127 ]
        Environment Tomcat 5.0.30, Linux, Oracle Tomcat 5.5.23, Windows XP, Oracle
        Martin Dulisch made changes -
        Attachment jetspeed_error.htm [ 12360663 ]
        Martin Dulisch made changes -
        Affects Version/s 2.1.1-RC [ 12312377 ]
        Affects Version/s 2.1.1 [ 12312462 ]
        Martin Dulisch made changes -
        Affects Version/s 2.1.1 [ 12312462 ]
        Affects Version/s 2.1.1-RC [ 12312377 ]
        Ate Douma added a comment -

        I still can't reproduce the problem, also not with opening an action link in a maximized portlet.

        Maybe you can try this out with the latest 2.1.1 installer (temporarily available at http://people.apache.org/~ate/jetspeed-2.1.1-demo-installer.jar)
        and if you can reproduce it, provide an exact sequence of interactions to do so.

        Martin Dulisch added a comment -

        I tried this out with the latest trunk version.
        Deployed with jetspeed maven plugin.

        I will try to create a minimal portlet application that produced this error and attach it to this issue.

        Ate Douma made changes -
        Assignee Ate Douma [ adouma ]
        Ate Douma added a comment -

        I finally managed to reproduce this issue.
        Turns out this problem only occurs when the user is on a page not accessible by the guest user.
        The url does contain the maximized windowId, but as the user is redirected to the default/login page, that window isn't available.
        Still the aggregator is trying to render (only) that window, leading to the reported error.

        I'm looking into a fix for this right now.

        Ate Douma made changes -
        Fix Version/s 2.1.2 [ 12312564 ]
        Ate Douma added a comment -

        Fixed.
        Now ignoring incoming portlet request parameters if the portlet isn't available (anymore), and possibly sending a SC_NOT_FOUND (ResourceURL) or doing a direct redirect to render (ActionURL)

        Ate Douma made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Ate Douma made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        305d 18m 1 Ate Douma 14/Apr/06 19:21
        Closed Closed Reopened Reopened
        438d 17h 44m 1 Martin Dulisch 27/Jun/07 13:06
        Reopened Reopened Resolved Resolved
        13d 1h 7m 1 Ate Douma 10/Jul/07 14:14
        Resolved Resolved Closed Closed
        1547d 8h 23m 1 Ate Douma 04/Oct/11 22:38

          People

          • Assignee:
            Ate Douma
            Reporter:
            Martin Dulisch
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development