Jetspeed 2
  1. Jetspeed 2
  2. JS2-1204

Portlet TLDs need to be configured in j2-admin's web.xml

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.2.2
    • Component/s: Admin Portlets
    • Labels:
      None

      Description

      When j2-admin app is deployed, the portlet TLD configurations are not added in web.xml automatically because it already has Jetspeed container servlet settings. However, this hasn't made any problem in Tomcat because Tomcat seems to load all TLDs in JAR from every accessible classloader; this behavior is slightly different from the JSP 2.0 Spec, where only jars in /WEB-INF/lib are to be looked up. (The pluto portlet tag lib jar file is deployed onto the shared lib path currently. I guess this was to conform the portlet spec, "portlet container must provide an implementation of portlet tags", which may be another issue.)
      Also, in other servlet container platforms where the automatic deployment option is not available, the missing TLD configurations in j2-admin's web.xml has made problems.
      So, at least, I think j2-admin should have the portlet TLD configurations by default.

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Woonsan Ko
            Reporter:
            Woonsan Ko
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development