Uploaded image for project: 'Jetspeed 2'
  1. Jetspeed 2
  2. JS2-1200

Toolbox portlet error when portal deployed as root app.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.2.2
    • Component/s: None
    • Labels:
      None

      Activity

      woon_san Woonsan Ko added a comment -

      This was caused by the misuses of portal context path.
      In JSTL's c:url tag, the contextPath must be slash leading; so for root context path, it must be '/', instead of empty string.
      On the other hand, in other most normal cases, the root context path is expected as empty string.
      Some pages have had confusion of these two different usages.
      So, added a new variable for portal context path to be used in jstl c:url tag.


        People

        • Assignee:
          woon_san Woonsan Ko
          Reporter:
          woon_san Woonsan Ko
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development