Jetspeed 2
  1. Jetspeed 2
  2. JS2-1117

Implement 1:1 Light Portal Site SiteView Variant

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.2.1
    • Labels:
      None
    • Environment:
      Jetui pipeline, new PageValve

      Description

      Implement lighter version of Portal Site component to supply menus, content mapping, and fallbacks for non-profiling PageValve. Will implement internally by swapping out SiteView implementation with a new one that implements a 1:1 pass-thru access to the underlying PageManager w/o using proxies.

        Activity

        Randy Watler added a comment -

        Commits:

        920191 - JS2-1117: enhance portal site implementation to support non-profiled physical site view
        920192 - JS2-1117: integrate portal site with non-profiled physical site view into PageValveImpl to supply standard menus, content mapping, and fallback rules capabilities

        Leaving issue open now until reviewed.

        Randy Watler added a comment -

        The 1:1 physical Portal Site component site view implementation has been tested extensively with the new non-profiling PageValve and appears to be functioning as intended.


          People

          • Assignee:
            Randy Watler
            Reporter:
            Randy Watler
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development