Jetspeed 2
  1. Jetspeed 2
  2. JS2-1107

The config custom mode has been broken since template psml feature was introduced.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.1
    • Component/s: Admin Portlets
    • Labels:
      None

      Description

      The config custom mode does not work at all with the following error:

      16.02.2010 11:23:18 ERROR [org.apache.jetspeed.request.RequestDiagnosticsImpl.writeLog():386]

      Id: G5QJQBI0
      Time: CET 2010-02-16 11:23:18:456
      Thread: Thread[http-18080-2,5,main]
      Internal: false
      User: admin
      Server: http://localhost:18080
      Remote IP address: 127.0.0.1
      Local IP address: 127.0.0.1
      Context path: /jetspeed
      Servlet path: /ui
      Path info: /ns:YnRlbXBsYXRlLXRvcDIucGFnZS10ZW1wbGF0ZS5kcC0xLmRwLTEwfGM0fGQwfGY/
      Request URI: /jetspeed/ui/ns:YnRlbXBsYXRlLXRvcDIucGFnZS10ZW1wbGF0ZS5kcC0xLmRwLTEwfGM0fGQwfGY/
      URL type: action
      Request method: POST
      Page path: /
      Page id: /default-page.psml
      Portlet application: webcontent
      Portlet: IFramePortlet
      Portlet window id: template-top2.page-template.dp-1.dp-10
      Error message: java.lang.IllegalStateException: Cannot find fragment: template-top2.page-template.dp-1.dp-10
      Exception: javax.portlet.PortletException: Failed to dispatch.include for Portlet Application: /webcontent, servlet: /container
      at: org.apache.jetspeed.container.invoker.ServletPortletInvoker.invoke(ServletPortletInvoker.java:174)
      at: org.apache.jetspeed.container.invoker.JetspeedPortletInvokerService.action(JetspeedPortletInvokerService.java:95)
      at: org.apache.pluto.container.impl.PortletContainerImpl.doAction(PortletContainerImpl.java:251)
      at: org.apache.jetspeed.container.JetspeedPortletContainerWrapper.doAction(JetspeedPortletContainerWrapper.java:75)
      at: org.apache.jetspeed.pipeline.valve.impl.ActionValveImpl.invoke(ActionValveImpl.java:95)
      at: org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:242)
      at: org.apache.jetspeed.container.ContainerValve.invoke(ContainerValve.java:88)
      at: org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:242)
      at: org.apache.jetspeed.container.PageHistoryValve.invoke(PageHistoryValve.java:108)
      at: org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:242)
      at: org.apache.jetspeed.profiler.impl.RefreshUserHomepageValveImpl.invoke(RefreshUserHomepageValveImpl.java:114)
      at: org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:242)
      at: org.apache.jetspeed.profiler.impl.ProfilerValveImpl.invoke(ProfilerValveImpl.java:289)
      at: org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:242)
      at: org.apache.jetspeed.security.impl.LoginValidationValveImpl.invoke(LoginValidationValveImpl.java:158)
      at: org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:242)
      at: org.apache.jetspeed.security.impl.PasswordCredentialValveImpl.invoke(PasswordCredentialValveImpl.java:151)
      at: org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:242)
      at: org.apache.jetspeed.localization.impl.LocalizationValveImpl.invoke(LocalizationValveImpl.java:170)
      at: org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:242)
      at: org.apache.jetspeed.security.impl.AbstractSecurityValve$1.run(AbstractSecurityValve.java:138)
      at: java.security.AccessController.doPrivileged(Native Method)
      at: javax.security.auth.Subject.doAsPrivileged(Subject.java:454)
      at: org.apache.jetspeed.security.JSSubject.doAsPrivileged(JSSubject.java:179)
      at: org.apache.jetspeed.security.impl.AbstractSecurityValve.invoke(AbstractSecurityValve.java:132)
      at: org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:242)
      at: org.apache.jetspeed.container.url.impl.PortalURLValveImpl.invoke(PortalURLValveImpl.java:88)
      at: org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:242)
      at: org.apache.jetspeed.capabilities.impl.CapabilityValveImpl.invoke(CapabilityValveImpl.java:127)
      at: org.apache.jetspeed.pipeline.JetspeedPipeline$Invocation.invokeNext(JetspeedPipeline.java:242)
      at: org.apache.jetspeed.pipeline.JetspeedPipeline.invoke(JetspeedPipeline.java:163)
      at: org.apache.jetspeed.engine.JetspeedEngine.service(JetspeedEngine.java:225)
      at: org.apache.jetspeed.engine.JetspeedServlet.invoke(JetspeedServlet.java:300)
      at: org.apache.jetspeed.engine.JetspeedServlet.service(JetspeedServlet.java:318)
      at: javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at: org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      at: org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at: org.apache.jetspeed.openid.filter.OpenIDPortalFilter.doFilter(OpenIDPortalFilter.java:95)
      at: org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at: org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at: org.apache.jetspeed.engine.servlet.XXSUrlAttackFilter.doFilter(XXSUrlAttackFilter.java:52)
      at: org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at: org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at: org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
      at: org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
      at: org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:433)
      at: org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
      at: org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      at: org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:568)
      at: org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at: org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
      at: org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
      at: org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
      at: org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
      at: java.lang.Thread.run(Thread.java:595)
      caused by: javax.servlet.ServletException: javax.portlet.PortletException: Failed to add security constraint.
      at: org.apache.jetspeed.container.JetspeedContainerServlet.doGet(JetspeedContainerServlet.java:375)
      at: org.apache.jetspeed.container.JetspeedContainerServlet.doPost(JetspeedContainerServlet.java:410)
      at: javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
      at: javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at: org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      at: org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at: org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:630)
      at: org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:535)
      at: org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:472)
      at: org.apache.jetspeed.container.invoker.ServletPortletInvoker.invoke(ServletPortletInvoker.java:165)
      at: org.apache.jetspeed.container.invoker.JetspeedPortletInvokerService.action(JetspeedPortletInvokerService.java:95)
      ... 53 more
      caused by: javax.portlet.PortletException: Failed to add security constraint.
      at: org.apache.jetspeed.portlets.custom.CustomConfigModePortlet.addSecurityConstraint(CustomConfigModePortlet.java:188)
      at: org.apache.jetspeed.portlets.custom.CustomConfigModePortlet.processAction(CustomConfigModePortlet.java:113)
      at: org.apache.jetspeed.factory.JetspeedPortletInstance.processAction(JetspeedPortletInstance.java:111)
      at: org.apache.jetspeed.portlet.PortletObjectProxy.proxyProcessAction(PortletObjectProxy.java:304)
      at: org.apache.jetspeed.portlet.PortletObjectProxy.invoke(PortletObjectProxy.java:177)
      at: $Proxy46.processAction(Unknown Source)
      at: org.apache.jetspeed.factory.JetspeedPortletInstance.processAction(JetspeedPortletInstance.java:111)
      at: org.apache.jetspeed.container.services.JetspeedFilterChain.doFilter(JetspeedFilterChain.java:112)
      at: org.apache.jetspeed.container.services.JetspeedFilterChain.processFilter(JetspeedFilterChain.java:88)
      at: org.apache.jetspeed.container.services.JetspeedFilterManager.processFilter(JetspeedFilterManager.java:107)
      at: org.apache.jetspeed.container.JetspeedContainerServlet.doGet(JetspeedContainerServlet.java:276)
      at: org.apache.jetspeed.container.JetspeedContainerServlet.doPost(JetspeedContainerServlet.java:410)
      ... 62 more
      caused by: java.lang.IllegalStateException: Cannot find fragment: template-top2.page-template.dp-1.dp-10
      at: org.apache.jetspeed.portlets.custom.CustomConfigModePortlet.addSecurityConstraint(CustomConfigModePortlet.java:142)
      at: org.apache.jetspeed.portlets.custom.CustomConfigModePortlet.processAction(CustomConfigModePortlet.java:113)
      ... 72 more

        Activity

        Woonsan Ko added a comment -

        Fixed with Randy's help. Thanks!
        By the way, the portlet window title problem (displaying "CustomConfigModePortlet" instead of the target portlet's title) has been fixed together.


          People

          • Assignee:
            Woonsan Ko
            Reporter:
            Woonsan Ko
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development