Jetspeed 2
  1. Jetspeed 2
  2. JS2-1095

simplest portal documentation broken

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.1
    • Component/s: Site Documentation
    • Labels:
      None

      Description

      http://portals.apache.org/jetspeed-2/devguide/guide-simple-portlet.html

      Following the deployment for the simplest portal doesn't work. It gives the error:

      DefaultValidationEventHandler: [FATAL_ERROR]: unexpected element (uri:"", local:"portlet-app"). Expected elements are <

      {http://java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd}

      portlet-app>,<

      {http://java.sun.com/xml/ns/portlet/portlet-app_2_0.xsd}

      portlet-app>
      Location: line 2

      changing line 2 of portlet.xml to:
      <portlet-app id="simplest" xmlns="http://java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd" version="1.0"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="http://java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd
      http://java.sun.com/xml/ns/portlet/portlet-app_1_0.xsd">

      works, although I'm not sure about the versions "1_0" or "2_0". Seems like either would work from the error message.

        Activity

        Amir Tahvildaran created issue -
        Amir Tahvildaran added a comment -

        And it seems the place for psml files is different, just "$CATALINA_HOME/pages", not $CATALINA_HOME/webapps/jetspeed/WEB-INF/pages

        -Amir

        Woonsan Ko added a comment -

        Hi Amir,

        Regarding the namespace issue in the portlet descriptor, it is not required any more to put namespace uri in the portlet descriptor from the next release, 2.2.1. This problem has been improved by the issue, https://issues.apache.org/jira/browse/JS2-1061.
        It will be enough to put "version" attribute without namespace uri for convenience. So, I think the documentation could be kept as it is.

        By the way, did you set another pages folder during installation? I think the default location is $CATALINA_HOME/webapps/jetspeed/WEB-INF/pages.
        If it is the case, I think we need to mention the location as a default one.

        -Woonsan

        Amir Tahvildaran added a comment -

        Thanks Woonsan.

        I'll update to 2.2.1 ASAP. How can I learn about the release schedule/road map? (Or can you tell me when 2.2.1 is GA?)

        Regarding the pages folder:
        I wasn't feeling adventurous for this first installation so I didn't intentionally change any defaults (followed http://portals.apache.org/jetspeed-2/getting-started-installer.html) I can double check this next install. I'm marking this as resolved, I'll reopen it if, when I reinstall 2.2.1, I find the pages directory defaults to $CATALINA_HOME, yes?

        Thanks again,
        Amir

        Amir Tahvildaran made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Not A Problem [ 8 ]
        Woonsan Ko added a comment -

        Hi Amir,

        I have no idea on the release schedule, but you can see the roadmap in David's blog article: http://davidseantaylor.blogspot.com/.
        And, regarding the pages folder, I didn't realize that the default pages folder had been changed since 2.2.0. I've just confirmed that the pages folder was created in $CATALINA_HOME/pages/. So, I'm reopening this issue for this problem.

        Thank you very much for pointing out this.

        Regards,

        Woonsan

        Woonsan Ko made changes -
        Resolution Not A Problem [ 8 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Woonsan Ko made changes -
        Assignee Woonsan Ko [ woon_san ]
        Woonsan Ko added a comment -

        Fixed the portal pages directory path with the default installation options.
        Thank you, Amir, for pointing out this problem.

        Woonsan

        Woonsan Ko made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Fix Version/s 2.2.1 [ 12313443 ]
        Resolution Fixed [ 1 ]
        Ate Douma made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Woonsan Ko
            Reporter:
            Amir Tahvildaran
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development