Jetspeed 2
  1. Jetspeed 2
  2. JS2-1077

Database Page Manager Cache test not running correctly in test suite

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.2.2
    • Component/s: PSML, Testing
    • Labels:
      None
    • Environment:
      Linux/2.2.1-SNAPSHOT/unit tests

      Description

      The following test works correctly from the jetspeed-page-manager folder:

      > mvn test -P test -Dtest=TestDatabasePageManagerCache

      however, this one does not:

      > mvn test -P test

      the TestDatabasePageManagerCache is skipped because it does not start the distributed caches correctly.

        Activity

        Randy Watler added a comment -

        Attempted to correct the invocation of this specific test case using multiple surefire test executions with different fork modes, but then maven 2.0.10 failed to launch the single test invocations correctly. Will need to test with newer versions of maven and/or surefire.

        May also have to find more deterministic fix that involves configuring and unconfiguring ehcache singletons correctly.

        Randy Watler added a comment -

        Patch attached to correct problem caused by static EhCacheConfigResource reconfiguration due to non-forked test execution.

        Randy Watler added a comment -

        Committed patch:

        JS2-1077: allow EhCache configuration to be reset during multiple in-process unit test runs

        Committed revision 931577


          People

          • Assignee:
            Randy Watler
            Reporter:
            Randy Watler
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development